Rear wiper issue 130i

Got a problem with your BMW 1 Series? Post your car problems here and seek advice from fellow car owners.

Moderators: babybmwadmin, marco_polo, Producethis, Lambster, Rich196

Post Reply
Cake_debauchery
Junior Member
Junior Member
Posts: 1
Joined: Tue Nov 21, 2017 2:15 pm

Rear wiper issue 130i

Post by Cake_debauchery » Tue Nov 21, 2017 2:21 pm

Hello

Just purchased a bmw 130i, massive upgrade to my peugeot 307 :P

I noticed the rear wiper was working but wasnt spraying, read through the forums regarding removing the wiper cap and pulling the black nozzle out and checking to see if it was clogged up with a pin, i did all this and it wasn't clogged.

I pushed the nozzle back in, put the cap back in place and now the rear wiper wont work.... every now and again it will work and go to 1 side but then come back and get stuck in the middle of the screen...

I'm not really sure what I could have done to cause this, wondered if anyone had any ideas? Im useless at this stuff so probably should have just left it!

Thanks

User avatar
marco_polo
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 47363
Joined: Tue Apr 06, 2010 9:40 am
Location: Omnipresent Post Whore

Re: Rear wiper issue 130i

Post by marco_polo » Tue Nov 21, 2017 2:46 pm

Relay ok? It's probably the mechanism in reality.

ECP sell lots of replacement rear wiper mechanisms as they leak internally in old age, rust up, and fail. (Don't forget to search around for ECP discount codes, there's usually a 30+% off somewhere.)
Silver F21 M135i - ManBox - HK - Adaptive + Eibach Pro's - BBS CH-R's - BMWP Drexler LSD - TMC Piggyback - M4 LCA's - aFe Dry Filter

Please help the Mod's by using the report [ ! ] button where appropriate

riccie_120i
Knowledgeable Member
Knowledgeable Member
Posts: 89
Joined: Tue Jul 18, 2017 12:57 pm

Re: Rear wiper issue 130i

Post by riccie_120i » Tue Nov 21, 2017 3:09 pm

here is my guide http://www.babybmw.net/viewtopic.php?f= ... 1#p1331971

managed to get it all working. as marco says, sounds like the motor and internals at fault.

User avatar
0l0dom0l0
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 2679
Joined: Sat Oct 18, 2014 6:48 pm

Re: Rear wiper issue 130i

Post by 0l0dom0l0 » Wed Nov 22, 2017 4:14 pm

Just replace the wiper motor. £60 or so from ecp for a valeo unit.
2007 130i LE - BMWP Exhaust, Strut Brace, Air Filter, Short Shift kit and Handbrake.
B12 KIT with M3 LCA and TS.
Plus Cruise Control, Digital Speedo, CDV Delete, Camber Pin Mod, OEM LED Numberplate Lights, Brighter Non-dimming OEM Angel Eyes.

Post Reply

Return to “BMW Problems”