Weird behaviour after xenon retrofit

Fancy some Angel Eyes, want to get rid of that yellow glow, want info on LED's, got a problem with your headlights, get your answers here

Moderators: Rich196, marco_polo, Producethis, Lambster

Arnie
Enthusiastic Member
Enthusiastic Member
Posts: 643
Joined: Mon Dec 01, 2014 1:31 pm

Re: Weird behaviour after xenon retrofit

Post by Arnie » Thu Jan 28, 2016 8:13 pm

I think you need to take apart the headlight.... Or new headlight?


Sent from my iPad using Tapatalk
2008' E82 135i

Arnie
Enthusiastic Member
Enthusiastic Member
Posts: 643
Joined: Mon Dec 01, 2014 1:31 pm

Re: Weird behaviour after xenon retrofit

Post by Arnie » Thu Jan 28, 2016 8:16 pm

0l0dom0l0 wrote:Don't know if you've addressed it, but you don't have halogen FTP on the LCI xenons. Pre LCI only I'm afraid.

Inner bulb is the halo bulb. So the FTP should be xenons shutters only.
My car 2008 pre lci e82 didnt have halogen ftp either, it looked same as headlight above just no eyebrow.

Ftp is xenon shutter you are correct, i think micheal has broken headlight in that case


Sent from my iPad using Tapatalk
2008' E82 135i

User avatar
0l0dom0l0
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 2848
Joined: Sat Oct 18, 2014 6:48 pm

Re: Weird behaviour after xenon retrofit

Post by 0l0dom0l0 » Thu Jan 28, 2016 9:59 pm

Arnie wrote:
0l0dom0l0 wrote:Don't know if you've addressed it, but you don't have halogen FTP on the LCI xenons. Pre LCI only I'm afraid.

Inner bulb is the halo bulb. So the FTP should be xenons shutters only.
My car 2008 pre lci e82 didnt have halogen ftp either, it looked same as headlight above just no eyebrow.

Ftp is xenon shutter you are correct, i think micheal has broken headlight in that case


Sent from my iPad using Tapatalk
Yes sorry, to be clear there are 3 versions of xenons. The first set which is pre 2007 cars, then lci xenons which is 2007 to 2009 ish, depending on model and the final set with eyebrows.

Only pre 2007 cars have the halogen FTP.

Sounds like he does indeed.
2007 130i LE - BMWP Exhaust, Strut Brace, Air Filter, Short Shift kit and Handbrake.
B12 KIT with M3 LCA and TS.
Plus Cruise Control, Digital Speedo, CDV Delete, Camber Pin Mod, OEM LED Numberplate Lights, Brighter Non-dimming OEM Angel Eyes.

MichalS
Knowledgeable Member
Knowledgeable Member
Posts: 150
Joined: Mon Dec 07, 2015 6:07 am

Re: Weird behaviour after xenon retrofit

Post by MichalS » Fri Jan 29, 2016 10:12 am

Anyone knows about DIY for changing bi-xenon lense in the headlight?

MIchael
E82 '08 120D, Black Sapphire
Retrofitted: Prof. HU, MULF2 + USB + Bluetooth, PDC Front and Back, Logic 7, Xenon front, black lines back.
To Go: Electric Heated seats, 335D engine + exhaust + gearbox + diff, sport brakes and suspension.

User avatar
0l0dom0l0
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 2848
Joined: Sat Oct 18, 2014 6:48 pm

Re: Weird behaviour after xenon retrofit

Post by 0l0dom0l0 » Fri Jan 29, 2016 11:07 am

MichalS wrote:Anyone knows about DIY for changing bi-xenon lense in the headlight?

MIchael
No but let me know if you find one or take the plunge.

Are you going to upgrade the projectors for clear lenses?
2007 130i LE - BMWP Exhaust, Strut Brace, Air Filter, Short Shift kit and Handbrake.
B12 KIT with M3 LCA and TS.
Plus Cruise Control, Digital Speedo, CDV Delete, Camber Pin Mod, OEM LED Numberplate Lights, Brighter Non-dimming OEM Angel Eyes.

MichalS
Knowledgeable Member
Knowledgeable Member
Posts: 150
Joined: Mon Dec 07, 2015 6:07 am

Re: Weird behaviour after xenon retrofit

Post by MichalS » Fri Jan 29, 2016 11:15 am

0l0dom0l0 wrote:
MichalS wrote:Anyone knows about DIY for changing bi-xenon lense in the headlight?

MIchael
No but let me know if you find one or take the plunge.

Are you going to upgrade the projectors for clear lenses?

No, I just want projector with working shutter.
E82 '08 120D, Black Sapphire
Retrofitted: Prof. HU, MULF2 + USB + Bluetooth, PDC Front and Back, Logic 7, Xenon front, black lines back.
To Go: Electric Heated seats, 335D engine + exhaust + gearbox + diff, sport brakes and suspension.

Arnie
Enthusiastic Member
Enthusiastic Member
Posts: 643
Joined: Mon Dec 01, 2014 1:31 pm

Re: Weird behaviour after xenon retrofit

Post by Arnie » Fri Jan 29, 2016 2:26 pm

0l0dom0l0 wrote:
MichalS wrote:Anyone knows about DIY for changing bi-xenon lense in the headlight?

MIchael
No but let me know if you find one or take the plunge.

Are you going to upgrade the projectors for clear lenses?

I tried to open once old headlight and honestly didn't see a way to do it without breaking something... they are sealed very well
2008' E82 135i

MichalS
Knowledgeable Member
Knowledgeable Member
Posts: 150
Joined: Mon Dec 07, 2015 6:07 am

Re: Weird behaviour after xenon retrofit

Post by MichalS » Fri Jan 29, 2016 8:21 pm

Update.

Connected jumper wires to the bonnets. from the jumpers small cables directly to the solenoid - b**tard works well. opens and closes like a dream. What does it mean? There was 11,5V on the plug which goes to the pins when i measured it yesterday? Should I increase the voltage somehow? Can it be done by coding? I'm scheduled in the workshop to remove the headlights as i wanted to give them buck to where i bought it...but now it seems like electrical problem.

Which line in the FRM coding data is responsible for the voltage for the shutters? PWM_...?
E82 '08 120D, Black Sapphire
Retrofitted: Prof. HU, MULF2 + USB + Bluetooth, PDC Front and Back, Logic 7, Xenon front, black lines back.
To Go: Electric Heated seats, 335D engine + exhaust + gearbox + diff, sport brakes and suspension.

Arnie
Enthusiastic Member
Enthusiastic Member
Posts: 643
Joined: Mon Dec 01, 2014 1:31 pm

Re: Weird behaviour after xenon retrofit

Post by Arnie » Fri Jan 29, 2016 10:19 pm

Are you using existing cables? Or you made new ones?


Sent from my iPad using Tapatalk
2008' E82 135i

MichalS
Knowledgeable Member
Knowledgeable Member
Posts: 150
Joined: Mon Dec 07, 2015 6:07 am

Re: Weird behaviour after xenon retrofit

Post by MichalS » Sat Jan 30, 2016 2:58 am

New ones
E82 '08 120D, Black Sapphire
Retrofitted: Prof. HU, MULF2 + USB + Bluetooth, PDC Front and Back, Logic 7, Xenon front, black lines back.
To Go: Electric Heated seats, 335D engine + exhaust + gearbox + diff, sport brakes and suspension.

Arnie
Enthusiastic Member
Enthusiastic Member
Posts: 643
Joined: Mon Dec 01, 2014 1:31 pm

Re: Weird behaviour after xenon retrofit

Post by Arnie » Sat Jan 30, 2016 8:22 am

MichalS wrote:New ones
What about pin2 ground? Is it new or existing?


Sent from my iPad using Tapatalk
2008' E82 135i

MichalS
Knowledgeable Member
Knowledgeable Member
Posts: 150
Joined: Mon Dec 07, 2015 6:07 am

Re: Weird behaviour after xenon retrofit

Post by MichalS » Sat Jan 30, 2016 10:02 am

It is also new, but good as the low beam works well. Could there be something wrong with it?
E82 '08 120D, Black Sapphire
Retrofitted: Prof. HU, MULF2 + USB + Bluetooth, PDC Front and Back, Logic 7, Xenon front, black lines back.
To Go: Electric Heated seats, 335D engine + exhaust + gearbox + diff, sport brakes and suspension.

Arnie
Enthusiastic Member
Enthusiastic Member
Posts: 643
Joined: Mon Dec 01, 2014 1:31 pm

Re: Weird behaviour after xenon retrofit

Post by Arnie » Sun Jan 31, 2016 8:31 am

MichalS wrote:It is also new, but good as the low beam works well. Could there be something wrong with it?
Not enough ground, what size cable have you used? It should be 2.5mm

I had similar issue on soft close install, and had voltage etc but when tried to engage locks didn't work.

Plug multimeter to those cables and see if you dont have voltage drop while trying to flash?


Sent from my iPad using Tapatalk
2008' E82 135i

MichalS
Knowledgeable Member
Knowledgeable Member
Posts: 150
Joined: Mon Dec 07, 2015 6:07 am

Re: Weird behaviour after xenon retrofit

Post by MichalS » Mon Feb 01, 2016 7:13 am

Ufff. Finished. Increased PWM_FL_BEI_BIXENON to 15.5V.

Everything is working now.

SO to sum up:

Third stop light - issue with the plug - pins 40 (third stop light) and 41 (HIGH Beam) connecting somehow within the plug.
Flash with Halogen - not possible on LCI regular xenon
Flash with BI-Xenon - make sure proper voltage on the shutter. Make sure ground wire from pin 2 is connected good to the bonnet.
Increased voltage for angel eyes for brighter rings - only works on FRM3
Xenon retrofit possible on FRM2 NSW (expcept making angel eyes brighter)

Thanks everyone for help!

BTW i have FRM2 NSW and FRM3 XE for sale. Both working well.

Michael
E82 '08 120D, Black Sapphire
Retrofitted: Prof. HU, MULF2 + USB + Bluetooth, PDC Front and Back, Logic 7, Xenon front, black lines back.
To Go: Electric Heated seats, 335D engine + exhaust + gearbox + diff, sport brakes and suspension.

User avatar
0l0dom0l0
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 2848
Joined: Sat Oct 18, 2014 6:48 pm

Re: Weird behaviour after xenon retrofit

Post by 0l0dom0l0 » Mon Feb 01, 2016 1:03 pm

MichalS wrote:Increased voltage for angel eyes for brighter rings - only works on FRM3
Xenon retrofit possible on FRM2 NSW (expcept making angel eyes brighter)Michael
Are you sure?

Because I've coded mine brighter on my 2007 130i LE, and I'd be amazed if this is a FRM 3.
2007 130i LE - BMWP Exhaust, Strut Brace, Air Filter, Short Shift kit and Handbrake.
B12 KIT with M3 LCA and TS.
Plus Cruise Control, Digital Speedo, CDV Delete, Camber Pin Mod, OEM LED Numberplate Lights, Brighter Non-dimming OEM Angel Eyes.

Post Reply

Return to “Interior/Exterior Lighting”