Just installed MHD

Get more out of your engine by remapping, tuning & chipping

Moderators: Rich196, marco_polo, Producethis, Lambster, babybmwadmin

miked5
Knowledgeable Member
Knowledgeable Member
Posts: 106
Joined: Tue Mar 01, 2016 4:48 am
Location: Barnard Castle

Just installed MHD

Post by miked5 » Tue Oct 10, 2017 5:38 pm

Now MHD has been out a while for N55 engine I thought I'd give it a shot, installed MHD Stage 1+ 93oct/98ron. Seems to pull a lot harder than my PPK tune that's for sure. Could anyone just have a look at my log and give their thoughts. Boost pressure seems to be a couple psi below target boost, is this nothing to worry about or signs of a slight boost leak?

https://datazap.me/u/miked5/wot-3rd-gea ... -10&solo=3
2011 135i N55 - PPK - M Performance Exhaust - Phoenix IC - Phoenix Chargepipe - MHD Stage 1+
Alpine White

Blind Pugh
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 8365
Joined: Wed Aug 28, 2013 6:36 am

Re: Just installed MHD

Post by Blind Pugh » Tue Oct 10, 2017 6:22 pm

What gear were you in for this datalog ?

Was TC fully off ?
Fettled M135i EB AT - gone but not forgotten !
AW M2 DCT

User avatar
.Griff.
Enthusiastic Member
Enthusiastic Member
Posts: 716
Joined: Sun Apr 12, 2015 12:54 pm
Location: Salop

Re: Just installed MHD

Post by .Griff. » Tue Oct 10, 2017 6:25 pm

Blind Pugh wrote:
Tue Oct 10, 2017 6:22 pm
What gear were you in for this datalog ?

Was TC fully off ?
Third, Fourth and Fifth if I'm reading it correctly.
Gone - 135i M Sport DCT, Just picked up - SO M140i Shadow Edition 8ZF MPE

gregk286
Knowledgeable Member
Knowledgeable Member
Posts: 115
Joined: Sat Feb 25, 2017 6:45 pm
Location: Lincolnshire

Re: Just installed MHD

Post by gregk286 » Tue Oct 10, 2017 6:38 pm

I would suggest posting here as it's the most active N55 thread around:
http://www.e90post.com/forums/showthread.php?t=1318714
2010 E82 Space Grey 135i Coupe - N55

miked5
Knowledgeable Member
Knowledgeable Member
Posts: 106
Joined: Tue Mar 01, 2016 4:48 am
Location: Barnard Castle

Re: Just installed MHD

Post by miked5 » Tue Oct 10, 2017 6:44 pm

Blind Pugh wrote:What gear were you in for this datalog ?

Was TC fully off ?
3rd gear for the WOT pull, yeah TC fully off


Sent from my iPhone using Tapatalk
2011 135i N55 - PPK - M Performance Exhaust - Phoenix IC - Phoenix Chargepipe - MHD Stage 1+
Alpine White

Blind Pugh
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 8365
Joined: Wed Aug 28, 2013 6:36 am

Re: Just installed MHD

Post by Blind Pugh » Tue Oct 10, 2017 7:16 pm

miked5 wrote:
Tue Oct 10, 2017 6:44 pm
Blind Pugh wrote:What gear were you in for this datalog ?

Was TC fully off ?
3rd gear for the WOT pull, yeah TC fully off


Sent from my iPhone using Tapatalk
If not making target it’s most likely yr target is too high for the fuel you are using - either reduce target or add octane yr fuel.
Fettled M135i EB AT - gone but not forgotten !
AW M2 DCT

miked5
Knowledgeable Member
Knowledgeable Member
Posts: 106
Joined: Tue Mar 01, 2016 4:48 am
Location: Barnard Castle

Re: Just installed MHD

Post by miked5 » Tue Oct 10, 2017 7:21 pm

I'm running Tesco99 so it should make target.

Is it likely that there could be a boost leak? I can't hear one mind.


Sent from my iPhone using Tapatalk
2011 135i N55 - PPK - M Performance Exhaust - Phoenix IC - Phoenix Chargepipe - MHD Stage 1+
Alpine White

Blind Pugh
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 8365
Joined: Wed Aug 28, 2013 6:36 am

Re: Just installed MHD

Post by Blind Pugh » Tue Oct 10, 2017 7:35 pm

Best way to check for leaks is spraying soapy water on joints then start her up and look for any bubbles....

I found TM99 use to vary in terms of quality. SVP is more consistent re octane
Last edited by Blind Pugh on Tue Oct 10, 2017 7:57 pm, edited 1 time in total.
Fettled M135i EB AT - gone but not forgotten !
AW M2 DCT

miked5
Knowledgeable Member
Knowledgeable Member
Posts: 106
Joined: Tue Mar 01, 2016 4:48 am
Location: Barnard Castle

Re: Just installed MHD

Post by miked5 » Tue Oct 10, 2017 7:48 pm

Yeah we do the same at work I'll give it a leak check this weekend.

I'll fill up with v-power next time and compare results.

Is there any negative effects of running as I am atm with it not reaching target boost, should I avoid WOT?


Sent from my iPhone using Tapatalk
2011 135i N55 - PPK - M Performance Exhaust - Phoenix IC - Phoenix Chargepipe - MHD Stage 1+
Alpine White

Blind Pugh
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 8365
Joined: Wed Aug 28, 2013 6:36 am

Re: Just installed MHD

Post by Blind Pugh » Tue Oct 10, 2017 8:00 pm

miked5 wrote:
Tue Oct 10, 2017 7:48 pm
Yeah we do the same at work I'll give it a leak check this weekend.

I'll fill up with v-power next time and compare results.

Is there any negative effects of running as I am atm with it not reaching target boost, should I avoid WOT?


Sent from my iPhone using Tapatalk
Do you have a code reader/clearer ? Does it flag up any errors?

To be honest DME protects the engine from knock and or running lean so you should OK

How many miles has you done with mhd before doing data logs? Might be yr car car is still adapting ???
Fettled M135i EB AT - gone but not forgotten !
AW M2 DCT

miked5
Knowledgeable Member
Knowledgeable Member
Posts: 106
Joined: Tue Mar 01, 2016 4:48 am
Location: Barnard Castle

Re: Just installed MHD

Post by miked5 » Tue Oct 10, 2017 8:07 pm

Yeah checked fault codes before and after mapping no error codes.

I have done around 50miles with MHD before that log.


Sent from my iPhone using Tapatalk
2011 135i N55 - PPK - M Performance Exhaust - Phoenix IC - Phoenix Chargepipe - MHD Stage 1+
Alpine White

Blind Pugh
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 8365
Joined: Wed Aug 28, 2013 6:36 am

Re: Just installed MHD

Post by Blind Pugh » Tue Oct 10, 2017 8:20 pm

miked5 wrote:
Tue Oct 10, 2017 8:07 pm
Yeah checked fault codes before and after mapping no error codes.

I have done around 50miles with MHD before that log.


Sent from my iPhone using Tapatalk
Yes - do nothing until you've done about 200-300 miles then reset throttle body adaptations then do about 3-4 WOT pulls in 3rd gear then do a datalogging WOT run.

I bet yr data will be consistent
Fettled M135i EB AT - gone but not forgotten !
AW M2 DCT

miked5
Knowledgeable Member
Knowledgeable Member
Posts: 106
Joined: Tue Mar 01, 2016 4:48 am
Location: Barnard Castle

Re: Just installed MHD

Post by miked5 » Tue Oct 10, 2017 8:28 pm

Ok thanks for the advice as ever BP


Sent from my iPhone using Tapatalk
2011 135i N55 - PPK - M Performance Exhaust - Phoenix IC - Phoenix Chargepipe - MHD Stage 1+
Alpine White

miked5
Knowledgeable Member
Knowledgeable Member
Posts: 106
Joined: Tue Mar 01, 2016 4:48 am
Location: Barnard Castle

Re: Just installed MHD

Post by miked5 » Mon Oct 23, 2017 2:02 pm

Just an update on this

After doing 300 miles+ my boost is still 2-3psi under target. I haven't been able to do a full leak check on the engine but I have removed my intercooler and charge pipe, everything fitted securely and all clamps tight. Fitted startdard parts and re-logged but boost is still down.

I'm guessing next is vacuum lines or diverter valves?

Does anyone know if it automatically resets adaptions when you flash a map?

https://datazap.me/u/miked5/stage-1-93o ... max=485.28

Mike
2011 135i N55 - PPK - M Performance Exhaust - Phoenix IC - Phoenix Chargepipe - MHD Stage 1+
Alpine White

miked5
Knowledgeable Member
Knowledgeable Member
Posts: 106
Joined: Tue Mar 01, 2016 4:48 am
Location: Barnard Castle

Re: Just installed MHD

Post by miked5 » Wed Dec 13, 2017 1:45 am

Finally got my car into work over the pit, pressure tested engine to 0.5bar no leaks found. What is the chance of it being vacuum lines? Could it be a faulty reading from the TMAP sensor? I'm half tempted to run a boost gauge short term straight from my charge pipe to compare.

https://datazap.me/u/miked5/post-thrott ... ata=3-4-13
2011 135i N55 - PPK - M Performance Exhaust - Phoenix IC - Phoenix Chargepipe - MHD Stage 1+
Alpine White

Post Reply

Return to “Engine Remapping/Tuning/Chipping”