SOS System Call Failure?

Find out more about the BMW 1 Series F20, F21, F22 & F23
Manufactured from end of 2011

Moderators: babybmwadmin, marco_polo, Producethis, Lambster, Rich196

JDK20_M135i
Knowledgeable Member
Knowledgeable Member
Posts: 113
Joined: Wed Jul 12, 2017 7:11 am

SOS System Call Failure?

Post by JDK20_M135i » Fri Sep 15, 2017 6:46 am

Morning lads,

Well last night, I was turning my car off and it came up with the SOS System Failure, and has been on by a little exclamation mark on my black screen since....

Does anyone know a way to fix this, or am i better off going down to my local dealer and asking them if they can shed some light on it?

JDK
BMW M135i - Glacier Silver, Auto, Red Leather, Pro Nav, HK, Sunroof, Front & Rear PDC, Heated & Electric Memory Seats, LSD, Motech Performance Eibach Springs & Carbon Spoiler.

spl23
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 2139
Joined: Tue Sep 12, 2006 11:10 am

Re: SOS System Call Failure?

Post by spl23 » Fri Sep 15, 2017 8:33 am

Looking online, someone claims to have fixed the problem by rebooting the iDrive system, deleting their phone from the Bluetooth interface and reconnecting it. No idea if it works, but worth a try before getting the dealer involved...

I'd suggest deleting the Bluetooth phone connection first, then rebooting iDrive (hold down the power button in the volume knob for 30 seconds, until the screen goes black and then shows the BMW ConnectedDrive logo, then release the button) and then re-pair your phone.
2015 F20 LCI 125i

JDK20_M135i
Knowledgeable Member
Knowledgeable Member
Posts: 113
Joined: Wed Jul 12, 2017 7:11 am

Re: SOS System Call Failure?

Post by JDK20_M135i » Fri Sep 15, 2017 8:50 am

spl23 wrote:
Fri Sep 15, 2017 8:33 am
Looking online, someone claims to have fixed the problem by rebooting the iDrive system, deleting their phone from the Bluetooth interface and reconnecting it. No idea if it works, but worth a try before getting the dealer involved...

I'd suggest deleting the Bluetooth phone connection first, then rebooting iDrive (hold down the power button in the volume knob for 30 seconds, until the screen goes black and then shows the BMW ConnectedDrive logo, then release the button) and then re-pair your phone.
Cheers bud! I'll give this a try when i finish work.

JDK
BMW M135i - Glacier Silver, Auto, Red Leather, Pro Nav, HK, Sunroof, Front & Rear PDC, Heated & Electric Memory Seats, LSD, Motech Performance Eibach Springs & Carbon Spoiler.

User avatar
tweeky
Enthusiastic Member
Enthusiastic Member
Posts: 573
Joined: Fri Dec 14, 2012 5:00 pm
Location: West Yorkshire

Re: SOS System Call Failure?

Post by tweeky » Fri Sep 15, 2017 2:45 pm

But the SOS system doesn't use your phone, the vehicle has an imbedded sim that it uses for the SOS system.
Current 2015 F22 Melbourne Red 220D loaded with many extras.
Gone 2012 E82 Space Grey 118D Sports Plus standard spec.

spl23
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 2139
Joined: Tue Sep 12, 2006 11:10 am

Re: SOS System Call Failure?

Post by spl23 » Fri Sep 15, 2017 3:24 pm

tweeky wrote:
Fri Sep 15, 2017 2:45 pm
But the SOS system doesn't use your phone, the vehicle has an imbedded sim that it uses for the SOS system.
True, but said embedded SIM is part of the ConnectedDrive system, so rebooting CD may help. There seemed some doubt on the site I saw as to whether removing and re-pairing the phone was necessary, but my experience of the strange interconnectedness of parts of the CD system (like the iPod crashing also knocking out the CD drive...) suggests it certainly won't hurt!
2015 F20 LCI 125i

User avatar
tweeky
Enthusiastic Member
Enthusiastic Member
Posts: 573
Joined: Fri Dec 14, 2012 5:00 pm
Location: West Yorkshire

Re: SOS System Call Failure?

Post by tweeky » Fri Sep 15, 2017 3:55 pm

true
Current 2015 F22 Melbourne Red 220D loaded with many extras.
Gone 2012 E82 Space Grey 118D Sports Plus standard spec.

JDK20_M135i
Knowledgeable Member
Knowledgeable Member
Posts: 113
Joined: Wed Jul 12, 2017 7:11 am

Re: SOS System Call Failure?

Post by JDK20_M135i » Sat Sep 16, 2017 11:43 am

spl23 wrote:
Fri Sep 15, 2017 8:33 am
Looking online, someone claims to have fixed the problem by rebooting the iDrive system, deleting their phone from the Bluetooth interface and reconnecting it. No idea if it works, but worth a try before getting the dealer involved...

I'd suggest deleting the Bluetooth phone connection first, then rebooting iDrive (hold down the power button in the volume knob for 30 seconds, until the screen goes black and then shows the BMW ConnectedDrive logo, then release the button) and then re-pair your phone.
Didn't manage to reboot the system, held the power button for god knows how long and it did nothing on the system...

Ended up booking it in at my local stealer for a diagnostic. £95+ vat. Outrage :x

I'll wait and see what they say, they didn't seam to know anything about it...so hopefully they can work something out for it.
BMW M135i - Glacier Silver, Auto, Red Leather, Pro Nav, HK, Sunroof, Front & Rear PDC, Heated & Electric Memory Seats, LSD, Motech Performance Eibach Springs & Carbon Spoiler.

spl23
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 2139
Joined: Tue Sep 12, 2006 11:10 am

Re: SOS System Call Failure?

Post by spl23 » Sat Sep 16, 2017 9:05 pm

JDK20_M135i wrote:
Sat Sep 16, 2017 11:43 am
spl23 wrote:
Fri Sep 15, 2017 8:33 am
Looking online, someone claims to have fixed the problem by rebooting the iDrive system, deleting their phone from the Bluetooth interface and reconnecting it. No idea if it works, but worth a try before getting the dealer involved...

I'd suggest deleting the Bluetooth phone connection first, then rebooting iDrive (hold down the power button in the volume knob for 30 seconds, until the screen goes black and then shows the BMW ConnectedDrive logo, then release the button) and then re-pair your phone.
Didn't manage to reboot the system, held the power button for god knows how long and it did nothing on the system...
You need to hold it down for far longer than seems ought to be necessary - I believe it is 30 seconds, but it seems like an age. You need to have the electrics in the car turned on, so there is something on the screen, and then just push in the volume knob as if muting the audio and don't let go until the screen goes black.
2015 F20 LCI 125i

JDK20_M135i
Knowledgeable Member
Knowledgeable Member
Posts: 113
Joined: Wed Jul 12, 2017 7:11 am

Re: SOS System Call Failure?

Post by JDK20_M135i » Sat Sep 16, 2017 10:41 pm

spl23 wrote:
Sat Sep 16, 2017 9:05 pm
JDK20_M135i wrote:
Sat Sep 16, 2017 11:43 am
spl23 wrote:
Fri Sep 15, 2017 8:33 am
Looking online, someone claims to have fixed the problem by rebooting the iDrive system, deleting their phone from the Bluetooth interface and reconnecting it. No idea if it works, but worth a try before getting the dealer involved...

I'd suggest deleting the Bluetooth phone connection first, then rebooting iDrive (hold down the power button in the volume knob for 30 seconds, until the screen goes black and then shows the BMW ConnectedDrive logo, then release the button) and then re-pair your phone.
Didn't manage to reboot the system, held the power button for god knows how long and it did nothing on the system...
You need to hold it down for far longer than seems ought to be necessary - I believe it is 30 seconds, but it seems like an age. You need to have the electrics in the car turned on, so there is something on the screen, and then just push in the volume knob as if muting the audio and don't let go until the screen goes black.
Okay, i'll try again tomorrow. However, I did hold it down for ages....

I was thinking of un-hooking the battery off the car, and seeing if that resets the iDrive and the SOS System failure..not 100% sure on what else that would do to the car. So i think that i will give that a miss.

Cheers for the help as well mate. Hopefully I can get it sorted out.
BMW M135i - Glacier Silver, Auto, Red Leather, Pro Nav, HK, Sunroof, Front & Rear PDC, Heated & Electric Memory Seats, LSD, Motech Performance Eibach Springs & Carbon Spoiler.

jeffj
Junior Member
Junior Member
Posts: 6
Joined: Mon Oct 23, 2017 9:47 pm

Re: SOS System Call Failure?

Post by jeffj » Wed Nov 15, 2017 10:06 pm

Hey mate did you manage to fix this? Having the same problem on mine.

oxfordshirerob
Junior Member
Junior Member
Posts: 27
Joined: Thu Oct 26, 2017 2:57 pm

Re: SOS System Call Failure?

Post by oxfordshirerob » Wed Nov 15, 2017 10:40 pm

jeffj wrote:
Wed Nov 15, 2017 10:06 pm
Hey mate did you manage to fix this? Having the same problem on mine.
Hey Jeff, mine too, do you have connected drive? Are any of you connected drive services working? Mine dropped out at same time and the connected drive team have directed me to the dealership for a telematic ECU reset. If that doesn't work then looks like a new ECU will be needed.

Apparently it may be an issue with the 'inbuilt SIM card within the telematic ECU. Car is booked in on Friday so I'll let you know the outcome.

jeffj
Junior Member
Junior Member
Posts: 6
Joined: Mon Oct 23, 2017 9:47 pm

Re: SOS System Call Failure?

Post by jeffj » Wed Nov 15, 2017 10:55 pm

oxfordshirerob wrote:
Wed Nov 15, 2017 10:40 pm
jeffj wrote:
Wed Nov 15, 2017 10:06 pm
Hey mate did you manage to fix this? Having the same problem on mine.
Hey Jeff, mine too, do you have connected drive? Are any of you connected drive services working? Mine dropped out at same time and the connected drive team have directed me to the dealership for a telematic ECU reset. If that doesn't work then looks like a new ECU will be needed.

Apparently it may be an issue with the 'inbuilt SIM card within the telematic ECU. Car is booked in on Friday so I'll let you know the outcome.
Hey man i just bought my 235i last sunday :( dreading it as its not under warranty. The weirdest thing for me was the the voice command and phone call doesn't take in my voice? Like mic doesn't work along with this SOS thing. As far as connected drive pretty sure its past the 3 year time limit

JDK20_M135i
Knowledgeable Member
Knowledgeable Member
Posts: 113
Joined: Wed Jul 12, 2017 7:11 am

Re: SOS System Call Failure?

Post by JDK20_M135i » Thu Nov 16, 2017 6:59 am

jeffj wrote:
Wed Nov 15, 2017 10:55 pm
oxfordshirerob wrote:
Wed Nov 15, 2017 10:40 pm
jeffj wrote:
Wed Nov 15, 2017 10:06 pm
Hey mate did you manage to fix this? Having the same problem on mine.
Hey Jeff, mine too, do you have connected drive? Are any of you connected drive services working? Mine dropped out at same time and the connected drive team have directed me to the dealership for a telematic ECU reset. If that doesn't work then looks like a new ECU will be needed.

Apparently it may be an issue with the 'inbuilt SIM card within the telematic ECU. Car is booked in on Friday so I'll let you know the outcome.
Hey man i just bought my 235i last sunday :( dreading it as its not under warranty. The weirdest thing for me was the the voice command and phone call doesn't take in my voice? Like mic doesn't work along with this SOS thing. As far as connected drive pretty sure its past the 3 year time limit

Hey Chaps, sorry I didn't realise that you'd commented on this post.

I did get mine fixed, it was the speaker in the drivers footwell that had broken/come away and was causing the SOS System Failure and the microphones not to work. So before any new ecu or anything get them to check that...only cost me £50.
BMW M135i - Glacier Silver, Auto, Red Leather, Pro Nav, HK, Sunroof, Front & Rear PDC, Heated & Electric Memory Seats, LSD, Motech Performance Eibach Springs & Carbon Spoiler.

oxfordshirerob
Junior Member
Junior Member
Posts: 27
Joined: Thu Oct 26, 2017 2:57 pm

Re: SOS System Call Failure?

Post by oxfordshirerob » Thu Nov 16, 2017 10:04 am

JDK20_M135i wrote:
Thu Nov 16, 2017 6:59 am
jeffj wrote:
Wed Nov 15, 2017 10:55 pm
oxfordshirerob wrote:
Wed Nov 15, 2017 10:40 pm


Hey Jeff, mine too, do you have connected drive? Are any of you connected drive services working? Mine dropped out at same time and the connected drive team have directed me to the dealership for a telematic ECU reset. If that doesn't work then looks like a new ECU will be needed.

Apparently it may be an issue with the 'inbuilt SIM card within the telematic ECU. Car is booked in on Friday so I'll let you know the outcome.
Hey man i just bought my 235i last sunday :( dreading it as its not under warranty. The weirdest thing for me was the the voice command and phone call doesn't take in my voice? Like mic doesn't work along with this SOS thing. As far as connected drive pretty sure its past the 3 year time limit

Hey Chaps, sorry I didn't realise that you'd commented on this post.

I did get mine fixed, it was the speaker in the drivers footwell that had broken/come away and was causing the SOS System Failure and the microphones not to work. So before any new ecu or anything get them to check that...only cost me £50.

Deffinately worth doing what JDK20 recommends, it took me about 15 minutes to locate the lower speaker and all was plugged in working OK on mine and I get a 'bong' noise when the SOS alert comes on, and thats where the noise is coming from, so it appears all that is working fine on mine. On mine however the system works fine making calls from/to my phone, its just the SOS and connected drive services that are not working.

Jeff I feel your pain with regards to the warranty, I purchased the comprehensive BMW insured warranty on mine when I bought the car (as I bought the car second hand not from BMW, the car was 3 years old when I bought it) which you can pay for monthly and as the issue is classed as electrical the dealer said they would look to replace under warranty......don't know how old your 235i is, but may be worth looking into that warranty to cover any other defects that may creep up, if the car is new to you. Can cancel it at anytime, so may be peace of mind for a year or so? I got mine direct from the extended warranty page on the BMW site: http://www.bmw.co.uk/en_GB/topics/finan ... edwarranty

Definitely worth following JDK20's advice first though as could save a load of money if its the same issue JDK20 had.

JDK20_M135i
Knowledgeable Member
Knowledgeable Member
Posts: 113
Joined: Wed Jul 12, 2017 7:11 am

Re: SOS System Call Failure?

Post by JDK20_M135i » Thu Nov 16, 2017 12:50 pm

oxfordshirerob wrote:
Thu Nov 16, 2017 10:04 am
JDK20_M135i wrote:
Thu Nov 16, 2017 6:59 am
jeffj wrote:
Wed Nov 15, 2017 10:55 pm


Hey man i just bought my 235i last sunday :( dreading it as its not under warranty. The weirdest thing for me was the the voice command and phone call doesn't take in my voice? Like mic doesn't work along with this SOS thing. As far as connected drive pretty sure its past the 3 year time limit

Hey Chaps, sorry I didn't realise that you'd commented on this post.

I did get mine fixed, it was the speaker in the drivers footwell that had broken/come away and was causing the SOS System Failure and the microphones not to work. So before any new ecu or anything get them to check that...only cost me £50.

Deffinately worth doing what JDK20 recommends, it took me about 15 minutes to locate the lower speaker and all was plugged in working OK on mine and I get a 'bong' noise when the SOS alert comes on, and thats where the noise is coming from, so it appears all that is working fine on mine. On mine however the system works fine making calls from/to my phone, its just the SOS and connected drive services that are not working.

Jeff I feel your pain with regards to the warranty, I purchased the comprehensive BMW insured warranty on mine when I bought the car (as I bought the car second hand not from BMW, the car was 3 years old when I bought it) which you can pay for monthly and as the issue is classed as electrical the dealer said they would look to replace under warranty......don't know how old your 235i is, but may be worth looking into that warranty to cover any other defects that may creep up, if the car is new to you. Can cancel it at anytime, so may be peace of mind for a year or so? I got mine direct from the extended warranty page on the BMW site: http://www.bmw.co.uk/en_GB/topics/finan ... edwarranty

Definitely worth following JDK20's advice first though as could save a load of money if its the same issue JDK20 had.
Yeah, mine was still bonging also. And that's where it was coming from, just weird that the SOS System Failure kept coming up. Are you sure that you've checked everything is plugged in, there might be a few wires that need plugging in and it might be missing one, as mine as still bonging and my connected drive wasn't working either...
BMW M135i - Glacier Silver, Auto, Red Leather, Pro Nav, HK, Sunroof, Front & Rear PDC, Heated & Electric Memory Seats, LSD, Motech Performance Eibach Springs & Carbon Spoiler.

Post Reply

Return to “F20, F21, F22, F23 (2011 - tbd)”