Fitted this bad boy in my F20 yesterday :D

Find out more about the BMW 1 Series F20, F21, F22 & F23
Manufactured from end of 2011

Moderators: Rich196, marco_polo, Producethis, babybmwadmin, Lambster

User avatar
BMW_120
Knowledgeable Member
Knowledgeable Member
Posts: 149
Joined: Thu Jul 27, 2017 3:58 pm
Location: SE

Re: Fitted this bad boy in my F20 yesterday :D

Post by BMW_120 » Tue Apr 03, 2018 2:59 pm

moghm wrote:
Tue Apr 03, 2018 1:33 pm
Hello everyone. Could do with a bit of help please. Great unit but a few issues.

1. no sound when playing, for example, you tube. I guess I need to connect the aux lead to the aux jack in armrest ? the post below says that u have to go to the original menu and select aux it, could someone please confirm exactly what needs to be done ?

2. whats best way to route the cable to the armrest please ?

3. I have a USB cable that I cant see it being connected anywhere, can anyone guide me on this pls ?

4. When I start the car first thing, screen seems to default to the original aux menu setting. Is there any way I can get it to switch to navigation on startup, granted the boot sequence takes a while ?

Sorry for all the questions. Thanks in advance
1. Yes, most likely you need to connect the AUX to the jack in the armrest. This varies from some cars and units though, I've heard some don't require this. When the AUX is connected, you simply select the AUX in external devices in the menu and you're good to go.

2. I posted some videos about this earlier in this thread: viewtopic.php?f=63&t=103291&p=1341735#p1341735

3. You need to be more clear with what you mean. "A USB cable" could be any cable. Is it one of the USB cables that came with the car? Do you remember plugging it in? If I remember correctly it goes directly into the screen, and splits into 2 or more USB inputs. Was a while since I installed the screen so can't remember. You can test if they work but simply plugging in your phone and see if it starts charging.

4. I'm not sure you can get it to switch over to the Android screen at first, but once you've switched manually you can use automation apps like AutoMate to have it launch the apps you want.
2013 120dA F20 SL Alpine White

moghm
Junior Member
Junior Member
Posts: 11
Joined: Thu Mar 08, 2018 6:11 pm

Re: Fitted this bad boy in my F20 yesterday :D

Post by moghm » Tue Apr 03, 2018 3:11 pm

Thankyou very much for the answers. Some further comments

1. Yes, most likely you need to connect the AUX to the jack in the armrest. This varies from some cars and units though, I've heard some don't require this. When the AUX is connected, you simply select the AUX in external devices in the menu and you're good to go.

I am assuming aux in external devices in the original BMW menu ?

2. I posted some videos about this earlier in this thread: viewtopic.php?f=63&t=103291&p=1341735#p1341735

Excellent, will take a look

3. You need to be more clear with what you mean. "A USB cable" could be any cable. Is it one of the USB cables that came with the car? Do you remember plugging it in? If I remember correctly it goes directly into the screen, and splits into 2 or more USB inputs. Was a while since I installed the screen so can't remember. You can test if they work but simply plugging in your phone and see if it starts charging.


The USB cable which came with the screen. There is like a 5/6 pin plug on the screen that is empty, i suspect that the riser cable that comes with the unit has not been provided and hence I cannot connect the USB cable to the screen, Need to look at this further. Ill take some pics and attach.

4. I'm not sure you can get it to switch over to the Android screen at first, but once you've switched manually you can use automation apps like AutoMate to have it launch the apps you want.

Thanks for this. Ill give this a go. Getting there slowly.

jordan
Experienced Member
Experienced Member
Posts: 267
Joined: Mon May 16, 2016 6:31 pm

Re: Fitted this bad boy in my F20 yesterday :D

Post by jordan » Mon Apr 09, 2018 6:14 pm

Did Anyone find a way to get spotify to skip tracks from the steering wheel after?

skribbler1
Junior Member
Junior Member
Posts: 41
Joined: Sat Sep 02, 2017 8:59 pm

Re: Fitted this bad boy in my F20 yesterday :D

Post by skribbler1 » Mon Apr 09, 2018 6:24 pm

jordan wrote:Did Anyone find a way to get spotify to skip tracks from the steering wheel after?
Nope! I have tried every way possible known to man with no luck. It worked the very first time I used the device and never since.

I do believe it all boils down to whether your car has native Bluetooth (which mine doesn't) in order to control Spotify through your phone (which in turn controls Spotify on the head unit too). If I'm wrong then someone please correct me and tell us how to get it working!

Also, does anyone know how to get the time on the headunit to stick? I've set the time manually, I've set it to sync with idrive, I've changed it to 24hours, back to am/pm... But it just doesn't stick. Any help would be greatly appreciated.

Sent from my SM-G950F using Tapatalk


User avatar
vded
Junior Member
Junior Member
Posts: 47
Joined: Thu Mar 12, 2015 9:44 am
Location: Greece (Kalamata)
Contact:

Re: Fitted this bad boy in my F20 yesterday :D

Post by vded » Mon Apr 09, 2018 6:25 pm

Set the time in settings to original time.
BMW F20 (2015) 116i M-Pack

skribbler1
Junior Member
Junior Member
Posts: 41
Joined: Sat Sep 02, 2017 8:59 pm

Re: Fitted this bad boy in my F20 yesterday :D

Post by skribbler1 » Mon Apr 09, 2018 6:28 pm

Did that with no luck. Sorry, that's what I meant when I said I set it to sync with idrive. Bad explanation, my apologies.

Sent from my SM-G950F using Tapatalk



moghm
Junior Member
Junior Member
Posts: 11
Joined: Thu Mar 08, 2018 6:11 pm

Re: Fitted this bad boy in my F20 yesterday :D

Post by moghm » Tue Apr 10, 2018 10:41 am

Hello,

Still working through various issues but also got a slight cosmetic issue. Please have a look at pics attached. When I boot up first thing in morning I get this screen. Got the igoxxxxx_ext displayed on the top left hand side and the icons are a bit different on the right hand side. Its almost like the entire system or the launcher has not competely loaded. All functions seem to work ok its just that its a bit ugly having the name of the program running. The right hand icons are also different to the normal screen. The only way i can get this to reinitialise is to switch car off and lock doors, then when it reboots again it is usually ok. Little annoying. Any ideas ?

Many thanks.
Attachments
yoko3.jpg
yoko3.jpg (202.57 KiB) Viewed 312 times
yoko5.jpg
yoko5.jpg (44.02 KiB) Viewed 312 times

User avatar
BMW_120
Knowledgeable Member
Knowledgeable Member
Posts: 149
Joined: Thu Jul 27, 2017 3:58 pm
Location: SE

Re: Fitted this bad boy in my F20 yesterday :D

Post by BMW_120 » Thu Apr 12, 2018 8:45 pm

Ever since I updated the firmware to the February 2018 version, my GPS has completely stopped working. Refuses to find a GPS connection.
Not sure if it's related to the firmware or if perhaps the antenna has fallen off/stopped working itself.

Will experiment a bit tomorrow and see if I can get it to work again. Just hope I won't have to open up everything again to make sure the antenna is in its place.
2013 120dA F20 SL Alpine White

User avatar
vded
Junior Member
Junior Member
Posts: 47
Joined: Thu Mar 12, 2015 9:44 am
Location: Greece (Kalamata)
Contact:

Re: Fitted this bad boy in my F20 yesterday :D

Post by vded » Fri Apr 13, 2018 10:05 am

BMW_120 wrote:
Thu Apr 12, 2018 8:45 pm
Ever since I updated the firmware to the February 2018 version, my GPS has completely stopped working. Refuses to find a GPS connection.
Not sure if it's related to the firmware or if perhaps the antenna has fallen off/stopped working itself.

Will experiment a bit tomorrow and see if I can get it to work again. Just hope I won't have to open up everything again to make sure the antenna is in its place.
I'm on latest AVIN's firmware.
I have fitted the GPS antenna behind the glove box that someone here had suggested. I went out on the road, I did 30min driving and no signal on the GPS. After that, I moved the antenna, on the dashboard, just next to the passengers pillar, went again on the road, on 3-4 mins (first time cold start) the GPS found around 10 satellites.
BMW F20 (2015) 116i M-Pack

User avatar
BMW_120
Knowledgeable Member
Knowledgeable Member
Posts: 149
Joined: Thu Jul 27, 2017 3:58 pm
Location: SE

Re: Fitted this bad boy in my F20 yesterday :D

Post by BMW_120 » Fri Apr 13, 2018 2:58 pm

vded wrote:
Fri Apr 13, 2018 10:05 am
BMW_120 wrote:
Thu Apr 12, 2018 8:45 pm
Ever since I updated the firmware to the February 2018 version, my GPS has completely stopped working. Refuses to find a GPS connection.
Not sure if it's related to the firmware or if perhaps the antenna has fallen off/stopped working itself.

Will experiment a bit tomorrow and see if I can get it to work again. Just hope I won't have to open up everything again to make sure the antenna is in its place.
I'm on latest AVIN's firmware.
I have fitted the GPS antenna behind the glove box that someone here had suggested. I went out on the road, I did 30min driving and no signal on the GPS. After that, I moved the antenna, on the dashboard, just next to the passengers pillar, went again on the road, on 3-4 mins (first time cold start) the GPS found around 10 satellites.
I guess I'll give that a go, too. Just mystical how all of a sudden it refuses to work when it's worked before.
Cheers
2013 120dA F20 SL Alpine White

Falltrack
Junior Member
Junior Member
Posts: 11
Joined: Sun Mar 04, 2018 9:51 am

Re: Fitted this bad boy in my F20 yesterday :D

Post by Falltrack » Fri Apr 13, 2018 8:54 pm

Looks like a great upgrade. I'm wondering if anyone sells them in all black, not too keen on the silver edge. Does it not look a bit cheap with that silve edge or is it fine? I've only seen photos and youtube reviews though.

User avatar
vded
Junior Member
Junior Member
Posts: 47
Joined: Thu Mar 12, 2015 9:44 am
Location: Greece (Kalamata)
Contact:

Re: Fitted this bad boy in my F20 yesterday :D

Post by vded » Fri Apr 13, 2018 9:05 pm

Falltrack wrote:Looks like a great upgrade. I'm wondering if anyone sells them in all black, not too keen on the silver edge. Does it not look a bit cheap with that silve edge or is it fine? I've only seen photos and youtube reviews though.
It blends wonderful in the car, even better if it's an M-Pack. You never notice it.
BMW F20 (2015) 116i M-Pack

moghm
Junior Member
Junior Member
Posts: 11
Joined: Thu Mar 08, 2018 6:11 pm

Re: Fitted this bad boy in my F20 yesterday :D

Post by moghm » Mon Apr 16, 2018 5:31 pm

Yeah, I have the all black version. Its got a black trim instead of the silver one. Please check my earlier post above, u can just make it out in the pic. Blends very well with my 120d SE. Bought it from yokotron in Hong Kong. £330 + £32 duty, let me know if ure interested. Its a Gen 2

Falltrack wrote:
Fri Apr 13, 2018 8:54 pm
Looks like a great upgrade. I'm wondering if anyone sells them in all black, not too keen on the silver edge. Does it not look a bit cheap with that silve edge or is it fine? I've only seen photos and youtube reviews though.

moghm
Junior Member
Junior Member
Posts: 11
Joined: Thu Mar 08, 2018 6:11 pm

Re: Fitted this bad boy in my F20 yesterday :D

Post by moghm » Mon Apr 16, 2018 5:38 pm

Im getting quite a good GPS signal at the moment after adjusting the position. It locks in like a few seconds. Ill try to explain where I have located it. GPS antenna is a magnetic one, reach over on the side of the vents once everything is removed, above the glove box, underneath the dash, there is a metal box, u can just about reach behind it and the GPS antenna will attach there via the magnet. Wire pointing down. Think someone mention direction can play a big part and it would seem so.

However, im a bit worried. Is this the box that houses the air bag. Air bag + explosive + magnetic GPS antenna = do we have a problem ?

Any thoughts ?

User avatar
BMW_120
Knowledgeable Member
Knowledgeable Member
Posts: 149
Joined: Thu Jul 27, 2017 3:58 pm
Location: SE

Re: Fitted this bad boy in my F20 yesterday :D

Post by BMW_120 » Sat Apr 28, 2018 6:12 pm

I'm reading about people getting much better GPS performance/success rates by extending the GPS antenna into the shark fin antenna. Probably not worth the effort, but if anyone's been looking for an alternate solution, I guess there you go
2013 120dA F20 SL Alpine White

Post Reply

Return to “F20, F21, F22, F23 (2011 - tbd)”