Pops and bangs stopped?

All things M135i related can be found in here

Moderators: Rich196, marco_polo, Producethis, Lambster, babybmwadmin

Glund91
Enthusiastic Member
Enthusiastic Member
Posts: 703
Joined: Tue Jun 27, 2017 10:25 pm

Pops and bangs stopped?

Post by Glund91 » Sat Feb 17, 2018 4:02 pm

Just been driving around in sport as per usual and my exhaust has suddenly just stopped popping and banging. I understand they are engineered in but has anyone else had this happen? Not sure what the cause could be.

Just in town so I'm hoping it's a bug and they'll be back when I turn it back on.
M140i Shadow in SO w/ MPE

Glund91
Enthusiastic Member
Enthusiastic Member
Posts: 703
Joined: Tue Jun 27, 2017 10:25 pm

Re: Pops and bangs stopped?

Post by Glund91 » Sat Feb 17, 2018 4:16 pm

Turned the car on and they've started happening again. But about 5 minutes later they've cut out again... tried flicking into comfort then Sport again and also tried Sport+ and they still won't come back.
M140i Shadow in SO w/ MPE

User avatar
Flat6
Experienced Member
Experienced Member
Posts: 227
Joined: Tue Jan 01, 2008 8:20 pm

Re: Pops and bangs stopped?

Post by Flat6 » Sat Feb 17, 2018 5:20 pm

Mine seems to do it less after a long run, when the whole exhaust is properly hot. Do you normally do fairly short journeys and therefore notice it more?


Sent from my iPhone using Tapatalk
M140i
Elise 111R
3.2 Carrera

Glund91
Enthusiastic Member
Enthusiastic Member
Posts: 703
Joined: Tue Jun 27, 2017 10:25 pm

Re: Pops and bangs stopped?

Post by Glund91 » Sat Feb 17, 2018 5:40 pm

Most of my journeys are short, but have done long ones as well and it's never stopped popping.

I have the MPE and res delete, and the pops are actually pretty brutal and it just stopped completely. Very noticeable.

With it being an ECU thing just wondering if it's something that the garage will look at under warranty.

Having a resonator deleted and/or MPE won't be blamed will they?
M140i Shadow in SO w/ MPE

User avatar
Mad_Mac
Experienced Member
Experienced Member
Posts: 354
Joined: Thu Nov 30, 2017 12:54 pm

Re: Pops and bangs stopped?

Post by Mad_Mac » Sat Feb 17, 2018 6:30 pm

Check if valve is open. That might be the reason.
F20 2015 M135i LCI manual, black, coral interior, comfort pack, black grill and MPE

Glund91
Enthusiastic Member
Enthusiastic Member
Posts: 703
Joined: Tue Jun 27, 2017 10:25 pm

Re: Pops and bangs stopped?

Post by Glund91 » Sat Feb 17, 2018 6:40 pm

I have the M Performance exhaust so it doesn't have the valve. Unless you mean a different valve in which case no idea.

Since I have had the resonator delete I am just worried it is something to do with that but then the other side of me is thinking loads of people have mid pipes, and it shouldn't have any effect on whether or not the exhaust pops.

On another note, from videos I have seen the M Performance Exhaust should still pop slightly in comfort but I have never had that. If it is supposed to pop in comfort then the issue has been there a longer amount of time.
M140i Shadow in SO w/ MPE

barneym140i
Experienced Member
Experienced Member
Posts: 210
Joined: Tue Jun 06, 2017 8:45 am

Re: Pops and bangs stopped?

Post by barneym140i » Sat Feb 17, 2018 6:41 pm

mine does it sometimes, always starts again, even though a res delete wouldnt cause it you will have a struggle convincing bmw otherwise and they will wriggle out of that since you have modified the exhaust

Glund91
Enthusiastic Member
Enthusiastic Member
Posts: 703
Joined: Tue Jun 27, 2017 10:25 pm

Re: Pops and bangs stopped?

Post by Glund91 » Sat Feb 17, 2018 6:44 pm

barneym140i wrote:
Sat Feb 17, 2018 6:41 pm
mine does it sometimes, always starts again, even though a res delete wouldnt cause it you will have a struggle convincing bmw otherwise and they will wriggle out of that since you have modified the exhaust
Yeah that is what I thought. Definitely will try their best to get out of it.

I love the pops and bangs though and if they have stopped I am not sure what I will do.

Maybe just bite the bullet and get a full BCS Mid pipe instead.
M140i Shadow in SO w/ MPE

barneym140i
Experienced Member
Experienced Member
Posts: 210
Joined: Tue Jun 06, 2017 8:45 am

Re: Pops and bangs stopped?

Post by barneym140i » Sat Feb 17, 2018 6:47 pm

they wouldnt stop with a mid pipe delete, they would be louder, I am assuming the pops are induced by ECU anyway with a squirt of extra fuel. So shouldnt be anything to do with a mid pipe

Glund91
Enthusiastic Member
Enthusiastic Member
Posts: 703
Joined: Tue Jun 27, 2017 10:25 pm

Re: Pops and bangs stopped?

Post by Glund91 » Sat Feb 17, 2018 6:57 pm

I just mean I got an exhaust fabricator to do the res delete so it could be (somehow?) caused by a poor fitment or something went wrong with it whereas BCS is a tried and tested product. That way if I have that and it still stops popping it is definitely ECU.

If it continue I might send it in to BMW anyway and see what they say.
M140i Shadow in SO w/ MPE

User avatar
NISFAN
Enthusiastic Member
Enthusiastic Member
Posts: 962
Joined: Sun Apr 02, 2017 12:46 pm
Location: Bedfordshire

Re: Pops and bangs stopped?

Post by NISFAN » Sat Feb 17, 2018 7:09 pm

Are you low on fuel? I vaguely remember a ‘fuel economy’ mode kicking in and stopping the pops.

Also, have you changed fuel recently? Mine pops less on SVP than mom99.

I’m sitting here with popcorn ready waiting to hear about your discussion with BMW


Sent from my iPhone using Tapatalk
M240i Auto

Glund91
Enthusiastic Member
Enthusiastic Member
Posts: 703
Joined: Tue Jun 27, 2017 10:25 pm

Re: Pops and bangs stopped?

Post by Glund91 » Sat Feb 17, 2018 7:12 pm

Just under half a tank left, and it has run fairly low in the past and never had an effect on pops and bangs. Had a full tank on Wednesday night and had no issues since then. Also I have never used anything other than Tesco Super Unleaded.

The thing that gets me is that it was like a switch. One minute it pops and bangs like a mofo and then it is just gone, overrun, downshifts, hard upshifts are all completely void of pops bangs and burbles. But like I said I restarted the car and they were back.

I know BMW will fight me but it is an engineered in product and I am fairly sure it will happen way before the rear resonator.
M140i Shadow in SO w/ MPE

User avatar
LadyBayImp
Experienced Member
Experienced Member
Posts: 403
Joined: Wed Jul 20, 2016 7:28 am

Re: Pops and bangs stopped?

Post by LadyBayImp » Sat Feb 17, 2018 8:08 pm

I’m pretty sure that mine has refused to pop when in sport mode on a few occasions. Flicking to comfort then back to sport seemed to sort it though.

From memory, this has been if I stick it in sport immediately after startup, as opposed to letting the cold start routine run its course in comfort, then switch to sport.
Mineral Grey M240i Convertible Auto. Chrome MPE, matte black MP diffuser, matte black grilles, JB+

Glund91
Enthusiastic Member
Enthusiastic Member
Posts: 703
Joined: Tue Jun 27, 2017 10:25 pm

Re: Pops and bangs stopped?

Post by Glund91 » Sat Feb 17, 2018 8:11 pm

I am usually in Sport mode straight away. Never really use any mode other than Sport.

I tried putting it in comfort, and also in Sport plus but it still wouldn't pop.

I am going to see if it happens again tomorrow and if it does get it looked at.

One of the reasons I picked this car is the pops and bangs so without them I would just end up selling the car I think.
M140i Shadow in SO w/ MPE

User avatar
NISFAN
Enthusiastic Member
Enthusiastic Member
Posts: 962
Joined: Sun Apr 02, 2017 12:46 pm
Location: Bedfordshire

Re: Pops and bangs stopped?

Post by NISFAN » Sat Feb 17, 2018 8:29 pm

Glund91 wrote:.....

I know BMW will fight me but it is an engineered in product and I am fairly sure it will happen way before the rear resonator.
It’s not a case of BMW fighting you......it’s more, what the hell can they do about it? The ECU doesn’t have a pops and bang knob that they can tweak up. If no codes, software is up to date and car generally runs as it should....what do you propose they do?


Sent from my iPhone using Tapatalk
M240i Auto

Post Reply

Return to “M135i/M235i/M140i/M240i”