Infotainment system problems and rear light lenses problem

Get your M2 fix here

Moderators: Rich196, marco_polo, Producethis, Lambster, babybmwadmin

Post Reply
Andy OH
Knowledgeable Member
Knowledgeable Member
Posts: 97
Joined: Mon Jan 30, 2017 3:57 pm

Infotainment system problems and rear light lenses problem

Post by Andy OH » Fri Feb 23, 2018 1:05 pm

Chaps,

Has anyone experienced the same problem in their M2 or M-Lite? On a few occasions the radio, phone connection and rear parking sensors on the car do not work, as in there is no sound, the display is working and that's it. Stop the car, turn off the ignition start again and it works. My wife took the car to BMW yesterday and they had no idea what it could be; they did suggest it may be a faulty amp? The car is booked in for early March but I just wondered if anyone had experienced the same issue?

The other problem is the rear light clusters having quite a bit of condensation inside them, they have already been replaced and the replacements are worse than the originals and will need replacing again. Has anyone else had the same issue?

Thanks,

Andy
M2 LBB DCT

CaptFish
Knowledgeable Member
Knowledgeable Member
Posts: 110
Joined: Fri Nov 10, 2017 1:27 pm

Re: Infotainment system problems and rear light lenses problem

Post by CaptFish » Fri Feb 23, 2018 1:11 pm

My Napster has recently packed in and I can't get it to work anymore.
I only have condensation in the front lights which comes and goes, so not too worried about it. Do you have condensation all the time?

Andy OH
Knowledgeable Member
Knowledgeable Member
Posts: 97
Joined: Mon Jan 30, 2017 3:57 pm

Re: Infotainment system problems and rear light lenses problem

Post by Andy OH » Fri Feb 23, 2018 1:50 pm

Yep, I have condensation constantly to the point it drips in both rear lenses.
M2 LBB DCT

Andy OH
Knowledgeable Member
Knowledgeable Member
Posts: 97
Joined: Mon Jan 30, 2017 3:57 pm

Re: Infotainment system problems and rear light lenses problem

Post by Andy OH » Fri Mar 30, 2018 9:22 am

Just to update this thread:

The car has now been to BMW twice to fix the intermittent problem with no sound coming from the speakers in the car. The first time they had the car for two days and just re-set the system. The second time they had the car three days and replaced the head unit (as they called it) and the amp for the Harmon Kardon speakers. Thankfully whilst the car was with them they experienced the fault with no sound coming from the speakers, hence changing both items. Hopefully now it is fixed. There is a rather good Facebook page for UK M2 owners and a few people on there have had similar problems with the amp needing replacing.

The rear light clusters still have no fix as BMW are aware that pre LCI cars are suffering condensation in the rear lights due to sealing problems (more like a design fault) and BMW are apparently working on a fix for this.
M2 LBB DCT

Post Reply

Return to “F87 M2”