mulf2 coding problems

E and F series coding & Diagnostics, performed on site and remotely.
Cable sales -- Loan cables – Cruise control retrofit options for all 1 & 2 series cars.
Coding options for all BMW cars and competitive prices.

Moderators: Rich196, marco_polo, Producethis, Lambster, babybmwadmin, BRDiagnostics

Post Reply
Matt_c
Junior Member
Junior Member
Posts: 38
Joined: Sun Oct 02, 2016 6:46 pm

mulf2 coding problems

Post by Matt_c » Sun Nov 20, 2016 9:10 pm

hi wibbles

my 135i was missing its mulf2 module when i bought it so i sourced a second hand one, so plugged it all in and took it to my friends who has icom but it was showing no communication and the ulf box red so i returned it and sourced another one this time we managed to get it in a green state ready for coding but it throws up a message saying theres no communications from the ulf i checked the MOST connection under the glove box and theres a red light and also when i plug the mulf2 in i get a red light in one of the optics ports so i would assume i have power there? as far as I'm aware don't all mulf2 units work across the range?

if you could shed some light on this i would be very grateful
2001 e46 m3 phoenix yellow now sold
2007 manual e82 135i sparkling graphite totally standard

User avatar
Wibbles
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 4904
Joined: Thu Feb 17, 2011 7:53 pm
Location: Tyne & Wear

Re: mulf2 coding problems

Post by Wibbles » Sun Nov 20, 2016 9:23 pm

I'd check that the MOST ring is complete. Also, does your friend know about setting the ICOM correctly?
F21 M135i - AW CR - lots of options.
Coding for all BMW's: Enquiries@BRdiagnostics.co.uk
Please visit my BabyBMW sponsors section: Here
BRD on Facebook

Matt_c
Junior Member
Junior Member
Posts: 38
Joined: Sun Oct 02, 2016 6:46 pm

Re: mulf2 coding problems

Post by Matt_c » Mon Nov 21, 2016 9:23 am

How do I check the most ring? Yeah he's pretty clued up on it he does Remaps and stuff but saying that we can't get it to work lol
2001 e46 m3 phoenix yellow now sold
2007 manual e82 135i sparkling graphite totally standard

User avatar
Wibbles
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 4904
Joined: Thu Feb 17, 2011 7:53 pm
Location: Tyne & Wear

Re: mulf2 coding problems

Post by Wibbles » Mon Nov 21, 2016 9:29 am

Are you connecting the ICOM MOST adaptor to the ring?
F21 M135i - AW CR - lots of options.
Coding for all BMW's: Enquiries@BRdiagnostics.co.uk
Please visit my BabyBMW sponsors section: Here
BRD on Facebook

Matt_c
Junior Member
Junior Member
Posts: 38
Joined: Sun Oct 02, 2016 6:46 pm

Re: mulf2 coding problems

Post by Matt_c » Mon Nov 21, 2016 9:36 am

No he's going in through the obd port by the Bonnet release
2001 e46 m3 phoenix yellow now sold
2007 manual e82 135i sparkling graphite totally standard

User avatar
Wibbles
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 4904
Joined: Thu Feb 17, 2011 7:53 pm
Location: Tyne & Wear

Re: mulf2 coding problems

Post by Wibbles » Mon Nov 21, 2016 11:57 am

Pretty sure you need the MOST adaptor in place as well, with the correct settings in easyconnect
F21 M135i - AW CR - lots of options.
Coding for all BMW's: Enquiries@BRdiagnostics.co.uk
Please visit my BabyBMW sponsors section: Here
BRD on Facebook

Matt_c
Junior Member
Junior Member
Posts: 38
Joined: Sun Oct 02, 2016 6:46 pm

Re: mulf2 coding problems

Post by Matt_c » Mon Nov 21, 2016 5:29 pm

ok mate thanks ill try and have another go and get back to you
2001 e46 m3 phoenix yellow now sold
2007 manual e82 135i sparkling graphite totally standard

Matt_c
Junior Member
Junior Member
Posts: 38
Joined: Sun Oct 02, 2016 6:46 pm

Re: mulf2 coding problems

Post by Matt_c » Mon Nov 28, 2016 3:54 pm

So tried it with the most connection connected and it still doesn't work it comes up with this fault code

S0112 no communication with ulf

But the unit shows up in the ecu spider diagram but is red not green
2001 e46 m3 phoenix yellow now sold
2007 manual e82 135i sparkling graphite totally standard

User avatar
Wibbles
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 4904
Joined: Thu Feb 17, 2011 7:53 pm
Location: Tyne & Wear

Re: mulf2 coding problems

Post by Wibbles » Mon Nov 28, 2016 4:03 pm

Did you use the MOST ASYNC mode?
F21 M135i - AW CR - lots of options.
Coding for all BMW's: Enquiries@BRdiagnostics.co.uk
Please visit my BabyBMW sponsors section: Here
BRD on Facebook

Matt_c
Junior Member
Junior Member
Posts: 38
Joined: Sun Oct 02, 2016 6:46 pm

Re: mulf2 coding problems

Post by Matt_c » Mon Nov 28, 2016 10:20 pm

I'm not to sure I've only been watching what he's been doing and learning as I go but the unit lets us replace it action list goes green with green tick then it does the final stage of measures? And then it comes up with a red cross and the final summary is the fault code I've said about above, it's really infuriating as I thought coding ulf was pretty simple and I've spent hours trying to sort it lol
2001 e46 m3 phoenix yellow now sold
2007 manual e82 135i sparkling graphite totally standard

User avatar
Wibbles
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 4904
Joined: Thu Feb 17, 2011 7:53 pm
Location: Tyne & Wear

Re: mulf2 coding problems

Post by Wibbles » Mon Nov 28, 2016 10:39 pm

I would use NCS Expert to code the MULF, it sounds like you're using ISTA D or P.
F21 M135i - AW CR - lots of options.
Coding for all BMW's: Enquiries@BRdiagnostics.co.uk
Please visit my BabyBMW sponsors section: Here
BRD on Facebook

Matt_c
Junior Member
Junior Member
Posts: 38
Joined: Sun Oct 02, 2016 6:46 pm

Re: mulf2 coding problems

Post by Matt_c » Mon Nov 28, 2016 11:13 pm

Yeah we are using ista p I believe is it easier with NCS expert we've got that too
2001 e46 m3 phoenix yellow now sold
2007 manual e82 135i sparkling graphite totally standard

User avatar
Wibbles
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 4904
Joined: Thu Feb 17, 2011 7:53 pm
Location: Tyne & Wear

Re: mulf2 coding problems

Post by Wibbles » Tue Nov 29, 2016 6:28 am

It's probably showing red because it's got the wrong VIN number for your car, use Tool32 to write the VIN then try ISTS/P
F21 M135i - AW CR - lots of options.
Coding for all BMW's: Enquiries@BRdiagnostics.co.uk
Please visit my BabyBMW sponsors section: Here
BRD on Facebook

Post Reply

Return to “BR Diagnostics & Retrofits”