Black Screen of Death

Check here to find out more about ICE, Satellite Navigation, Telecoms etc.

Moderators: Rich196, babybmwadmin, marco_polo, Producethis, Lambster

Post Reply
AndyLoudon
Junior Member
Junior Member
Posts: 6
Joined: Sat Mar 11, 2017 8:58 am

Black Screen of Death

Post by AndyLoudon » Thu Aug 09, 2018 7:56 am

(x-posted with the BMW Problems forum - but this post has an update)

The iDrive/screen on my 2014 F20 116i has gone on the fritz. It appears to be taking forever to boot up when the car is started, but often never quite manages to boot before my journey is over!

I took it into my local BMW dealer, who had a quick look. After establishing I wasn't being an idiot and missing something obvious they agreed to take a closer look when the car is in for its service next week. Someone suggested the battery voltage may be too low for the system to boot properly (hence why it eventually comes on), but not sure about the validity of this.

I've done some digging, but can't see anyone posting anywhere online with the same issue. I see posts about the screen being completely dead, but this isn't the same as it sometimes DOES eventually boot up. Any suggestions/ideas folks? What about the battery voltage being low?

UPDATE: Tried the reset (hold power button etc...) but that hasn't worked. Took the car on a long-ish drive to try and charge the battery a bit, but that hasn't changed anything. Checked the fuses, but they are all okay. Still want the dealer to look at it, but wondered if it could be a software glitch or loose connection somewhere?

Post Reply

Return to “In Car Entertainment, Communication & Sat Nav”