Help Needed with Car Audio :)

Check here to find out more about ICE, Satellite Navigation, Telecoms etc.

Moderators: Rich196, babybmwadmin, marco_polo, Producethis, Lambster

Post Reply
Jmaloney
Junior Member
Junior Member
Posts: 43
Joined: Thu Apr 26, 2018 9:23 am

Help Needed with Car Audio :)

Post by Jmaloney » Tue Jun 05, 2018 8:18 pm

Evening Guys,

I would really appreciate some help from you guys, i have upgraded the audio in my car over the weekend and its absolutely sh*t! I upgraded the fronts to HK mids and tweeters, then dynomatted the doors. They sound really good and the tweeters add so much depth to the sound!

I also installed 2 x Earthquake SWS subs, ran new wiring to the boot to an aftermarket amp. This is wired through a 4 channel LOC that is wired via a splitter that i bought incorrectly for the tweeters.

The bass is absolutely sh*te, i would say worse than standard, so here lies my question WTF has gone wrong? I have read some rear speakers are filtered? The amp works fine its all wired correctly and should have them little subs kicking!

Its a 2011 F20 116d Sport if this makes a difference

Any suggestions greatly appreciated!

oxfordshirerob
Knowledgeable Member
Knowledgeable Member
Posts: 67
Joined: Thu Oct 26, 2017 2:57 pm

Re: Help Needed with Car Audio :)

Post by oxfordshirerob » Thu Jun 07, 2018 5:37 pm

Jmaloney wrote:
Tue Jun 05, 2018 8:18 pm
Evening Guys,

I would really appreciate some help from you guys, i have upgraded the audio in my car over the weekend and its absolutely sh*t! I upgraded the fronts to HK mids and tweeters, then dynomatted the doors. They sound really good and the tweeters add so much depth to the sound!

I also installed 2 x Earthquake SWS subs, ran new wiring to the boot to an aftermarket amp. This is wired through a 4 channel LOC that is wired via a splitter that i bought incorrectly for the tweeters.

The bass is absolutely sh*te, i would say worse than standard, so here lies my question WTF has gone wrong? I have read some rear speakers are filtered? The amp works fine its all wired correctly and should have them little subs kicking!

Its a 2011 F20 116d Sport if this makes a difference

Any suggestions greatly appreciated!
Hi,

I don't know how techy you are, so just ignore me if this is obvious........but did you wire the subs in the right polarity? I think its quite easy to reverse the connections, in which case your subs will be sucking, not kicking (excuse the pun).

Like I said, ignore me if this is all obvious stuff, but I am just planning my foray into upgrading my system and getitng all the advice I can and this seems a common mistake people make.

Cheers

Jmaloney
Junior Member
Junior Member
Posts: 43
Joined: Thu Apr 26, 2018 9:23 am

Re: Help Needed with Car Audio :)

Post by Jmaloney » Thu Jun 07, 2018 7:57 pm

oxfordshirerob wrote:
Thu Jun 07, 2018 5:37 pm
Jmaloney wrote:
Tue Jun 05, 2018 8:18 pm
Evening Guys,

I would really appreciate some help from you guys, i have upgraded the audio in my car over the weekend and its absolutely sh*t! I upgraded the fronts to HK mids and tweeters, then dynomatted the doors. They sound really good and the tweeters add so much depth to the sound!

I also installed 2 x Earthquake SWS subs, ran new wiring to the boot to an aftermarket amp. This is wired through a 4 channel LOC that is wired via a splitter that i bought incorrectly for the tweeters.

The bass is absolutely sh*te, i would say worse than standard, so here lies my question WTF has gone wrong? I have read some rear speakers are filtered? The amp works fine its all wired correctly and should have them little subs kicking!

Its a 2011 F20 116d Sport if this makes a difference

Any suggestions greatly appreciated!
Hi,

I don't know how techy you are, so just ignore me if this is obvious........but did you wire the subs in the right polarity? I think its quite easy to reverse the connections, in which case your subs will be sucking, not kicking (excuse the pun).

Like I said, ignore me if this is all obvious stuff, but I am just planning my foray into upgrading my system and getitng all the advice I can and this seems a common mistake people make.

Cheers
Hi Rob,

Thanks for the reply, i have sorted it now it was the rear speakers! as soon as it was rewired to the old sub speakers it was 1000 times better!

oxfordshirerob
Knowledgeable Member
Knowledgeable Member
Posts: 67
Joined: Thu Oct 26, 2017 2:57 pm

Re: Help Needed with Car Audio :)

Post by oxfordshirerob » Thu Jun 07, 2018 8:55 pm

Jmaloney wrote:
Thu Jun 07, 2018 7:57 pm
oxfordshirerob wrote:
Thu Jun 07, 2018 5:37 pm
Jmaloney wrote:
Tue Jun 05, 2018 8:18 pm
Evening Guys,

I would really appreciate some help from you guys, i have upgraded the audio in my car over the weekend and its absolutely sh*t! I upgraded the fronts to HK mids and tweeters, then dynomatted the doors. They sound really good and the tweeters add so much depth to the sound!

I also installed 2 x Earthquake SWS subs, ran new wiring to the boot to an aftermarket amp. This is wired through a 4 channel LOC that is wired via a splitter that i bought incorrectly for the tweeters.

The bass is absolutely sh*te, i would say worse than standard, so here lies my question WTF has gone wrong? I have read some rear speakers are filtered? The amp works fine its all wired correctly and should have them little subs kicking!

Its a 2011 F20 116d Sport if this makes a difference

Any suggestions greatly appreciated!
Hi,

I don't know how techy you are, so just ignore me if this is obvious........but did you wire the subs in the right polarity? I think its quite easy to reverse the connections, in which case your subs will be sucking, not kicking (excuse the pun).

Like I said, ignore me if this is all obvious stuff, but I am just planning my foray into upgrading my system and getitng all the advice I can and this seems a common mistake people make.

Cheers
Hi Rob,

Thanks for the reply, i have sorted it now it was the rear speakers! as soon as it was rewired to the old sub speakers it was 1000 times better!
AHH yes, as I understand it, the rears are essentially just fill speakers, with no bass tones driven to them. Glad you have it sorted, hope it sounds great.

As a matter of interest, where did you mount the amp?

Jmaloney
Junior Member
Junior Member
Posts: 43
Joined: Thu Apr 26, 2018 9:23 am

Re: Help Needed with Car Audio :)

Post by Jmaloney » Thu Jun 07, 2018 9:30 pm

It’s just placed in the recess near the battery at the moment as a temporary measure.

Post Reply

Return to “In Car Entertainment, Communication & Sat Nav”