E91 Aftermarket Stereo Install - No Power

Check here to find out more about ICE, Satellite Navigation, Telecoms etc.

Moderators: Producethis, babybmwadmin, Rich196, Lambster, marco_polo

Post Reply
mrbcsd
Junior Member
Junior Member
Posts: 4
Joined: Tue Feb 12, 2019 2:18 pm

E91 Aftermarket Stereo Install - No Power

Post by mrbcsd » Tue Feb 12, 2019 2:23 pm

Good afternoon, I have just installed a new Kenwood KMM-BT504DAB using a https://www.dynamicsounds.co.uk/bmw-1-3 ... erial.html and have no power to it.

I haven’t split the red cable to the fuse box yet as I was under the impression that this was only needed for the settings to remain when the engine is off (Bluetooth/ radio stations etc). Could it be that this is what will be providing the power?

I have a 56 plate 320d M Sport.

User avatar
marco_polo
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 53098
Joined: Tue Apr 06, 2010 9:40 am
Location: Omnipresent Post Whore

Re: E91 Aftermarket Stereo Install - No Power

Post by marco_polo » Tue Feb 12, 2019 2:33 pm

I thought yellow was permanent live for Settings Memory? Red is switchable from the ignition, no?
Silver F21 M135i - ManBox - HK - Adaptive + Eibach Pro's - BBS CH-R's - BMWP Drexler LSD - M4 LCA's

Please help the Mod's by using the report [ ! ] button where appropriate

User avatar
Nottsknots
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 2868
Joined: Sat Jun 29, 2013 8:35 pm

Re: E91 Aftermarket Stereo Install - No Power

Post by Nottsknots » Tue Feb 12, 2019 3:30 pm

The dynamic sounds site says connect red to fusebox.

Hmmm.. how many times have I seen the need to swap yellow and red? (Rhetorical).

If memory serves, I think it HAS to have both red and yellow with power before that one turns on. If you only have one, then its not going to play ball. Wire up the other, then see how it goes.

Then set the presets, turn everything off and lock up for half an hour, and see if it retains the memory. If not swap those pesky red and yellows - some need it, some dont, and I have not found any sense to why.

If you’re still having problems, post a pic of the back of that quadlock connector, and both sides of the connection into the HU. Anything can be checked from those.
E87 118d, stock, plus PDC control unit drain, Parrot, debadged, Mothercare baby shades (but no babies), and occassionally a good layer of wax. Instantly forgettable, and thats the way I like it.

Not long now until the end of May...

mrbcsd
Junior Member
Junior Member
Posts: 4
Joined: Tue Feb 12, 2019 2:18 pm

Re: E91 Aftermarket Stereo Install - No Power

Post by mrbcsd » Tue Feb 12, 2019 7:59 pm

Thanks for this, I’m collecting my breakout blade fuses tomorrow after work to take a look at this. Are there any wiring diagrams you have come across to do this at all so I make sure I’m doing it correctly?

User avatar
Nottsknots
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 2868
Joined: Sat Jun 29, 2013 8:35 pm

Re: E91 Aftermarket Stereo Install - No Power

Post by Nottsknots » Tue Feb 12, 2019 8:38 pm

https://www.newtis.info/tisv2/a/en/

Select your vehicle, search for junction box, and you’ll have access to the fusebox wiring, which leads to everything you could ever need :)
E87 118d, stock, plus PDC control unit drain, Parrot, debadged, Mothercare baby shades (but no babies), and occassionally a good layer of wax. Instantly forgettable, and thats the way I like it.

Not long now until the end of May...

mrbcsd
Junior Member
Junior Member
Posts: 4
Joined: Tue Feb 12, 2019 2:18 pm

Re: E91 Aftermarket Stereo Install - No Power

Post by mrbcsd » Fri Feb 15, 2019 10:24 pm

Thanks all, appreciate the help. I have tapped the red wire from the ISO adapter into the existing stereo fuse in the box however this is not turning on and off with the ignition. It does remember the time, date, paired phones and stations so I just turn it off when I get out the car.

Ignition fuse is 30a and stereo running on a 10a so didn’t want to risk swapping that out!

I’ll keep testing then move on to the steering column controls.


Sent from my iPhone using Tapatalk

mrbcsd
Junior Member
Junior Member
Posts: 4
Joined: Tue Feb 12, 2019 2:18 pm

E91 Aftermarket Stereo Install - No Power

Post by mrbcsd » Sun Feb 17, 2019 2:51 pm

So here’s how it went in the end:

- Insulated spade connectors connected the breakout 10a fuse to the red wire from the back of the stereo
- The fuse went into a vacant slot in gap 14 (marked up as DSG/Gear Indicator/Active Cruise/SMG) which is 7.5a

Image

Now the stereo comes on ONLY when the start/stop button is pressed regardless of the engine being on or off!

Exactly what I wanted, hopefully this helps someone in the future.


Sent from my iPhone using Tapatalk

Post Reply

Return to “In Car Entertainment, Communication & Sat Nav”