E88 heater blower speed not working correctly after replacement

Got a problem with your BMW 1 Series? Post your car problems here and seek advice from fellow car owners.

Moderators: Lambster, marco_polo, Producethis, babybmwadmin, Rich196

Ash14297
Junior Member
Junior Member
Posts: 38
Joined: Fri Apr 20, 2018 9:33 pm

Re: E88 heater blower speed not working correctly after replacement

Post by Ash14297 » Tue Feb 05, 2019 11:24 am

marco_polo wrote:
Tue Feb 05, 2019 10:54 am
Some Auto's were so polluting they didn't bother trying to lower the emissions with Stop/Start.

Have you fitted a healthy battery yet? Trying to fix error codes/electrical gremlins caused by a poorly battery, whilst still having a poorly battery, is asking for a hiding.
Ok good point - I'll focus on this first :lol:

More questions though - as I said before, usually have no problem changing batteries but never touched one in a BMW, and looks a little confusing with the intelligent sensor on the top. Guessing it's still pretty simple though and it's a case of removing the sensor, then removing the battery in the normal way? Also, noticing there's standard batteries or AGM batteries - no idea what I need but will check what is already in the car. Seems like AGM batteries are needed for Start/Stop vehicles which we've already established my model does not have. So I'm guessing the following battery should be ok and can register it via Carly.

https://www.carparts4less.co.uk/cp4l/c/ ... 11e&000020

Ash14297
Junior Member
Junior Member
Posts: 38
Joined: Fri Apr 20, 2018 9:33 pm

Re: E88 heater blower speed not working correctly after replacement

Post by Ash14297 » Tue Feb 05, 2019 11:35 am

Although on second thoughts, Yuasa is recommending an AGM battery.... I'm guessing this is to do with the regenerative braking system
2019-02-05_11-34-46.jpg
2019-02-05_11-34-46.jpg (35.58 KiB) Viewed 113 times

User avatar
marco_polo
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 53859
Joined: Tue Apr 06, 2010 9:40 am
Location: Omnipresent Post Whore

Re: E88 heater blower speed not working correctly after replacement

Post by marco_polo » Tue Feb 05, 2019 12:45 pm

I would expect all BMW's after 2007 to have an AGM, easy to swap over but make sure you remember to code it to the car.
Silver F21 M135i - ManBox - HK - Adaptive + Eibach Pro's - BBS CH-R's - BMWP Drexler LSD - M4 LCA's

Please help the Mod's by using the report [ ! ] button where appropriate

Ash14297
Junior Member
Junior Member
Posts: 38
Joined: Fri Apr 20, 2018 9:33 pm

Re: E88 heater blower speed not working correctly after replacement

Post by Ash14297 » Tue Feb 05, 2019 1:10 pm

marco_polo wrote:
Tue Feb 05, 2019 12:45 pm
I would expect all BMW's after 2007 to have an AGM, easy to swap over but make sure you remember to code it to the car.
Perfect, thanks for all your advice! Will try replacing it over the weekend. :D

User avatar
stevesurrey
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 2068
Joined: Sun Nov 07, 2010 12:56 pm
Location: Surrey

Re: E88 heater blower speed not working correctly after replacement

Post by stevesurrey » Tue Feb 05, 2019 3:41 pm

I believe most batteries have some sort of manufacturing date marked on one of the poles. If so that should confirm if it's original or not. If it is original then at 9 years old it's likely nearing the end of its life.
E81 120D (N47) SE+Dynamic Package, 2007/57, M Sports Suspension, Montego Blue, Pro HU+HiFi Speakers & Dipstick

Ash14297
Junior Member
Junior Member
Posts: 38
Joined: Fri Apr 20, 2018 9:33 pm

Re: E88 heater blower speed not working correctly after replacement

Post by Ash14297 » Sat Apr 13, 2019 1:59 pm

Just wanted to update on this one in case anyone else has similar/random “shutdowns”.... this did turn out to be my battery.

Got a great deal with Tayna batteries (couldn’t recommend them enough based on price and efficient delivery)... installed in less than 30 mins, coded with Carly and solved all my weird error codes :spotman:

User avatar
stevesurrey
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 2068
Joined: Sun Nov 07, 2010 12:56 pm
Location: Surrey

Re: E88 heater blower speed not working correctly after replacement

Post by stevesurrey » Sat Apr 13, 2019 7:06 pm

Good to hear you got it all sorted and how! :)
E81 120D (N47) SE+Dynamic Package, 2007/57, M Sports Suspension, Montego Blue, Pro HU+HiFi Speakers & Dipstick

Post Reply

Return to “BMW Problems”