BMW 1 Series E81 2008 - Parking Sensor Issue and Low Oil Level

Got a problem with your BMW 1 Series? Post your car problems here and seek advice from fellow car owners.

Moderators: babybmwadmin, Producethis, marco_polo, Lambster, Rich196

Post Reply
Samuro
Junior Member
Junior Member
Posts: 4
Joined: Mon Aug 16, 2021 12:29 am

BMW 1 Series E81 2008 - Parking Sensor Issue and Low Oil Level

Post by Samuro »

Hi all,

*EDITED*

I did have a P0030 code for Bank 1 Sensor 1 issue, replaced that and it's gone.

Two remaining ssues, not sure how easy to fix and if something I can do.

1 - PDC: Each sensor, when put in reverse, clicks and vibrates, front and back checked. The light comes on as well. No beep when put in reverse to say it audibally activated, just the light comes on or any audible noise if close to an object (no visiual display for this one). I did check the PDC unit, but seemed okay, from an initial external inspection, was cable tied higher up than in the polystyrene holder, so not sure if water damage. But car had starting issues and has been jumped a few times as battery was really low and recently had to be smart charged as well, maybe a short or the buzzer done in?

Codes I had from a local mechanic were 9E33, 9E35 x 2, 9E34, 9E38, 9E37, 9E39 and 9E3A - which I think are just all the 8 sensors. But they all click and vibrate so I am assuming they work? I checked for the buzzer at the back right, near the PDC unit somewhere - Business Unit Dash, thought it would be around there, but don't see anything.

2 - Low Oil Level - 2F9E: Had a service recently, oil replaced etc. If car is on for a while, it will light up on the little display on the dash then go. Oil was replaced, I did top it up a quart or so, but did nothing. Is this just a case of replacing the sensor?

Any ideas for those?

Thanks.
Last edited by Samuro on Fri Oct 01, 2021 2:35 pm, edited 1 time in total.
User avatar
tweeky
Enthusiastic Member
Enthusiastic Member
Posts: 1482
Joined: Fri Dec 14, 2012 5:00 pm
Location: West Yorkshire

Re: BMW 1 Series E81 2008 - Few Issues... Parking Sensors No Audio, Low Oil Warning and P0030 Code

Post by tweeky »

Current 2018 F22 M240i Sunset Orange Black leather with lumber support, Pro Nav, Adaptive LEDs, HK, Sunroof F&R PDC + many more.
Gone 2015 F22 220D Melbourne Red loaded with many extras.
Gone 2012 E82 Space Grey 118D Sports Plus standard spec.
Samuro
Junior Member
Junior Member
Posts: 4
Joined: Mon Aug 16, 2021 12:29 am

Re: BMW 1 Series E81 2008 - Parking Sensor Issue and Low Oil Level

Post by Samuro »

Hi mate,

Yeah, I found it to be the O2 Sensor in the front, wasn't sure if there was anything to check on it, but replaced it and it's gone. Now just the last two issues :D
Nyxeris
Too Much Time To Waste Member
Too Much Time To Waste Member
Posts: 3128
Joined: Sat Mar 30, 2019 3:49 pm

Re: BMW 1 Series E81 2008 - Parking Sensor Issue and Low Oil Level

Post by Nyxeris »

This thread has lots of helpful info, including a pic of roughly where your rear PDC speaker should be. If that's gone walkies, I'd find one from a breakers via eBay and see if that solves the issue.

viewtopic.php?t=101346

On most E8x models (you haven't mentioned yours) the oil level sensor sits in the bottom of the sump, so it can't be changed without draining the oil. You could check continuity on the wires etc. but if your sensor is at the bottom and it does look like it's knackered you'll be on the hook for a fresh oil change too.
E81 130i | Thread
───────────────────────────
Click here for BabyBMW stickers!
Samuro
Junior Member
Junior Member
Posts: 4
Joined: Mon Aug 16, 2021 12:29 am

Re: BMW 1 Series E81 2008 - Parking Sensor Issue and Low Oil Level

Post by Samuro »

Nyxeris wrote: Fri Oct 01, 2021 3:15 pm This thread has lots of helpful info, including a pic of roughly where your rear PDC speaker should be. If that's gone walkies, I'd find one from a breakers via eBay and see if that solves the issue.

viewtopic.php?t=101346

On most E8x models (you haven't mentioned yours) the oil level sensor sits in the bottom of the sump, so it can't be changed without draining the oil. You could check continuity on the wires etc. but if your sensor is at the bottom and it does look like it's knackered you'll be on the hook for a fresh oil change too.
Thanks for this. I think I saw that thread. I couldn't even find where the connector would be for the buzzer if it had gone walkies. I looked in the exact area, as think it normalls sits up in the corner out of sight... but nothing there. Not sure if with rear/front sensors there's two buzzers. But will have another look I think.

It's an E81, so will require another oil change as you mention. Not sure if there's a way to clean the sensor like with a flush, but not sure it's worth to do that to only have the issue again, then to finally change the sensor with ANOTHER oil change haha.
Samuro
Junior Member
Junior Member
Posts: 4
Joined: Mon Aug 16, 2021 12:29 am

Re: BMW 1 Series E81 2008 - Parking Sensor Issue and Low Oil Level

Post by Samuro »

So, replaced the sensor and oil... had the clock then INACTIVE... then re-started the car and then clock and then +1ltr, thought great it's working, got the car off stands and level, tried again, INACTIVE, let it run for a bit and re-started +1ltr... great! Went for a drive, INACTIVE, INACTIVE... INACTIVE! Not sure what's going on.

Old sensor was just always throwing up low oil, even after a 20-30 min drive back and forward from places. One issue I noticed, the battery seems to be losing charge... quickly. Maybe causing some issues?

Not sure what to do or if a dealer jobby. Preferably like to learn this myself, but not sure I have all the tools/scan tools to diagnose further. Maybe a battery replacement will do, have a 10 year warranty and was only a year or 2 old (previous died after a long long time idle and not touched).

The parking sensor issues can be 'parked' for now. I found where the 2nd buzzer would most likely be - so will give that a look see.
Post Reply

Return to “BMW Problems”