Retrofit Adaptive Led S552A Problem

Find out more about the BMW 1 Series F20, F21, F22 & F23
Manufactured from end of 2011

Moderators: Rich196, babybmwadmin, marco_polo, Producethis, Lambster

Post Reply
s-type
Junior Member
Junior Member
Posts: 23
Joined: Fri Jul 08, 2016 8:39 pm

Retrofit Adaptive Led S552A Problem

Post by s-type » Thu Nov 08, 2018 5:45 pm

Hi, I made a wiring harness for a 552 adaptive led, all made same as official bmw retrofit.

I have brand new headlights with brand new modules. My car is 11/2011 with regular halogen lights.

I added 552 code to VO, but problem is that FLE modules should come after coding VO but they don't.

Do You know maybe where is problem ? Do I need to update I-step because my vehicle is from 11/2011, do I need somehow to teach-in modules because they are brand new unused ?


Thanks in advance.

Ogb666
Experienced Member
Experienced Member
Posts: 368
Joined: Sun Oct 15, 2017 12:23 pm

Re: Retrofit Adaptive Led S552A Problem

Post by Ogb666 » Thu Nov 08, 2018 7:49 pm

modules should show but you’ll need to inject the cafd into FLE 43 and FLE 44 and after that you can vo code.....

s-type
Junior Member
Junior Member
Posts: 23
Joined: Fri Jul 08, 2016 8:39 pm

Re: Retrofit Adaptive Led S552A Problem

Post by s-type » Thu Nov 08, 2018 10:51 pm

nothing showing, maybe i need to program moduls somehow because they are brand new ?


Sent from my iPhone using Tapatalk Pro

Ogb666
Experienced Member
Experienced Member
Posts: 368
Joined: Sun Oct 15, 2017 12:23 pm

Re: Retrofit Adaptive Led S552A Problem

Post by Ogb666 » Thu Nov 08, 2018 11:18 pm

Have you connected them to the can or can2 connection from the fem?im betting if you followed a diagram for a 2013 onwards loom that will be your problem.

s-type
Junior Member
Junior Member
Posts: 23
Joined: Fri Jul 08, 2016 8:39 pm

Re: Retrofit Adaptive Led S552A Problem

Post by s-type » Thu Nov 08, 2018 11:56 pm

I used KCAN2 yellow/brown(can low) and yellow/red(can high)

How can I fix the problem ?

Thanks for your help

Ogb666
Experienced Member
Experienced Member
Posts: 368
Joined: Sun Oct 15, 2017 12:23 pm

Re: Retrofit Adaptive Led S552A Problem

Post by Ogb666 » Fri Nov 09, 2018 12:19 am

change build date to 07/2015 and try coding again

s-type
Junior Member
Junior Member
Posts: 23
Joined: Fri Jul 08, 2016 8:39 pm

Re: Retrofit Adaptive Led S552A Problem

Post by s-type » Fri Nov 09, 2018 12:28 am

Yes I changed "zeitkriterium" from 11/11 to 11/15 ( that's latest which esys allows me to calculate FA ), but FLE module's not showing.

Headlights and modules are bought directly from BMW and they weren't been on any car yet, can that be problem maybe ?

Ogb666
Experienced Member
Experienced Member
Posts: 368
Joined: Sun Oct 15, 2017 12:23 pm

Re: Retrofit Adaptive Led S552A Problem

Post by Ogb666 » Fri Nov 09, 2018 12:29 am

Double check the wiring:
https://www.newtis.info/tisv2/a/en/f30- ... 1VnYd41yYc

If not try programming with ista

s-type
Junior Member
Junior Member
Posts: 23
Joined: Fri Jul 08, 2016 8:39 pm

Re: Retrofit Adaptive Led S552A Problem

Post by s-type » Fri Nov 09, 2018 12:43 am

I checked 100x, I'm going crazy :(, communication between module and headlights isn't good, low beam and blinkers working even without FLE, strange.

Ogb666
Experienced Member
Experienced Member
Posts: 368
Joined: Sun Oct 15, 2017 12:23 pm

Re: Retrofit Adaptive Led S552A Problem

Post by Ogb666 » Fri Nov 09, 2018 12:53 am

Program with ista:
Vehicle Management > Service function > Body > Lighting

Post Reply

Return to “F20, F21, F22, F23 (2011 - tbd)”