Voice command button - just makes a noise

Find out more about the BMW 1 Series F20, F21, F22 & F23
Manufactured from end of 2011

Moderators: Rich196, babybmwadmin, marco_polo, Producethis, Lambster

Post Reply
aneng
Junior Member
Junior Member
Posts: 8
Joined: Mon Jan 02, 2017 1:12 am

Voice command button - just makes a noise

Post by aneng » Fri Dec 15, 2017 6:35 am

Hi.

I've always had very flaky results when using the voice command button to send voice commands to my Android phone. From what I can gather, the button on my car (F20, 116d, base model, no nav) appears to just open a channel to the phone's own voice recognition system (i.e. it replaces you saying "OK Google"). I've recently switched to a new Samsung phone and now, when I press the voice command button on the steering wheel, all I get is a continuous DTMF (push button dial) tone.

Has anyone else experienced this ?

Ta !

wallacio
Junior Member
Junior Member
Posts: 5
Joined: Fri Oct 07, 2016 3:20 pm

Re: Voice command button - just makes a noise

Post by wallacio » Sat Dec 16, 2017 7:45 pm

Ha - yes!

I too have a Samsung (S6) and it's worked fine ever since I got the car but today, it has started doing exactly what you have just described.

I am guessing that it's Google who have updated the app but that's only a guess, but since nothing else has changed this is not unreasonable.

Very annoying, I use it all the time for selecting music!
Pov spec M140i: 3dr, 8AT, VO

aneng
Junior Member
Junior Member
Posts: 8
Joined: Mon Jan 02, 2017 1:12 am

Re: Voice command button - just makes a noise

Post by aneng » Sun Dec 17, 2017 1:12 am

Thanks for replying. I can point the finger at the phone now, rather than the car. Annoyingly, the "OK Google" feature has suddenly become barely functional on the phone outside of the car connection. Weirdly, it can correctly understand anything I say, even quietly, once I've pressed the mic button in the Google app, but has incredible difficulty in recognising "OK Google" !

wallacio
Junior Member
Junior Member
Posts: 5
Joined: Fri Oct 07, 2016 3:20 pm

Re: Voice command button - just makes a noise

Post by wallacio » Tue Jan 23, 2018 2:39 pm

In case you (or anyone else) is still experiencing this - it's an acknowledged bug in the Google app.

https://productforums.google.com/forum/ ... /websearch

I've signed up to the Google Beta tester programme but yet to see if the new version fixes the issue as suggested. A fix is apparently coming out in February though.

rustyk
Knowledgeable Member
Knowledgeable Member
Posts: 82
Joined: Mon May 29, 2017 7:40 pm

Re: Voice command button - just makes a noise

Post by rustyk » Tue Jan 23, 2018 9:07 pm

Awesome, I've just noticed this and I have the S6 too...

User avatar
fez_7
Experienced Member
Experienced Member
Posts: 279
Joined: Fri Jan 19, 2018 1:33 pm

Re: Voice command button - just makes a noise

Post by fez_7 » Wed Jan 24, 2018 12:18 pm

I have basic iDrive, standard Bluetooth for calls only without a combox. I have paired my iPhone but the button doesn’t do anything on the steering wheel. When I hold the iPhone button though then it works for Siri through the car’s speakers.

Post Reply

Return to “F20, F21, F22, F23 (2011 - tbd)”