Rear Windscreen Heater not working

Got a problem with your BMW 1 Series? Post your car problems here and seek advice from fellow car owners.

Moderators: Rich196, babybmwadmin, marco_polo, Producethis, Lambster

Post Reply
parin
Junior Member
Junior Member
Posts: 25
Joined: Sat Jul 30, 2011 2:28 pm

Rear Windscreen Heater not working

Post by parin » Sun Nov 06, 2011 11:05 am

My rear windscreen heater has stopped working on my 2007 118d (E81). The wing mirrors heat up when the rear heater button is pressed.

Anyone had a similar issue? Or know what to look for?

I've removed the trim and the connector seems ok.

User avatar
Deezer-D
Enthusiastic Member
Enthusiastic Member
Posts: 1545
Joined: Thu Sep 08, 2011 8:59 pm

Re: Rear Windscreen Heater not working

Post by Deezer-D » Sun Nov 06, 2011 11:21 am

Check the fuse?

parin
Junior Member
Junior Member
Posts: 25
Joined: Sat Jul 30, 2011 2:28 pm

Re: Rear Windscreen Heater not working

Post by parin » Sun Nov 06, 2011 12:55 pm

Fuses are fine.

russell hayward
Knowledgeable Member
Knowledgeable Member
Posts: 91
Joined: Wed Jan 03, 2007 1:11 pm

Re: Rear Windscreen Heater not working

Post by russell hayward » Mon Jan 23, 2012 10:38 am

Mine has done the same, was this fixed ?

User avatar
weasley
Enthusiastic Member
Enthusiastic Member
Posts: 761
Joined: Tue Jun 20, 2006 1:35 pm
Location: Reading, UK

Re: Rear Windscreen Heater not working

Post by weasley » Mon Jan 23, 2012 11:07 am

Just an observation, but the mirrors are not linked to the rear heated screen, so this is a bit of a red herring in fault diagnosis.

I'd be looking at the connectors on the rear screen and looking for any breaks in the fine wiring on the screen. If nothing obvious, and the fuse is OK, then it might be the switch. If not, then unless you fancy tracing the wiring it'll need diagnosis by a specialist.
130i M-Sport
2007 (56)
Le Mans Blue
Gone, but never forgotten.

Post Reply

Return to “BMW Problems”